summaryrefslogtreecommitdiffstats
path: root/Tests/ComplexOneConfig/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2007-03-12 14:23:06 (GMT)
committerBrad King <brad.king@kitware.com>2007-03-12 14:23:06 (GMT)
commitcf7eeab37aa644a0a09cb40e8958d99e8d771857 (patch)
tree26654def4fd4d24ad01f258be6ab7ca446390fcb /Tests/ComplexOneConfig/CMakeLists.txt
parentc03217d5609488b997313517abbac69abcabebc8 (diff)
downloadCMake-cf7eeab37aa644a0a09cb40e8958d99e8d771857.zip
CMake-cf7eeab37aa644a0a09cb40e8958d99e8d771857.tar.gz
CMake-cf7eeab37aa644a0a09cb40e8958d99e8d771857.tar.bz2
ENH: Testing new target properties RUNTIME_OUTPUT_DIRECTORY, LIBRARY_OUTPUT_DIRECTORY, and ARCHIVE_OUTPUT_DIRECTORY. This is an incremental fix for bug#2240 and bug#4210.
Diffstat (limited to 'Tests/ComplexOneConfig/CMakeLists.txt')
-rw-r--r--Tests/ComplexOneConfig/CMakeLists.txt10
1 files changed, 3 insertions, 7 deletions
diff --git a/Tests/ComplexOneConfig/CMakeLists.txt b/Tests/ComplexOneConfig/CMakeLists.txt
index deb0800..88acae8 100644
--- a/Tests/ComplexOneConfig/CMakeLists.txt
+++ b/Tests/ComplexOneConfig/CMakeLists.txt
@@ -137,13 +137,9 @@ SET(FORCE_TEST 0 CACHE STRING "a test" FORCE)
#
# Lib and exe path
#
-SET (LIBRARY_OUTPUT_PATH
- ${Complex_BINARY_DIR}/bin/ CACHE INTERNAL
- "Single output directory for building all libraries.")
-
-SET (EXECUTABLE_OUTPUT_PATH
- ${Complex_BINARY_DIR}/bin/ CACHE INTERNAL
- "Single output directory for building all executables.")
+SET(CMAKE_ARCHIVE_OUTPUT_DIRECTORY "${Complex_BINARY_DIR}/lib/static")
+SET(CMAKE_LIBRARY_OUTPUT_DIRECTORY "${Complex_BINARY_DIR}/lib")
+SET(CMAKE_RUNTIME_OUTPUT_DIRECTORY "${Complex_BINARY_DIR}/bin")
MESSAGE (Test " " escape " " semi-colon " " \; \;)
#