summaryrefslogtreecommitdiffstats
path: root/Tests/CustomCommand/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2010-12-20 17:09:23 (GMT)
committerBrad King <brad.king@kitware.com>2010-12-20 17:09:23 (GMT)
commit4499d50ad2df7c1db4335d40f9fa20c642f59a5d (patch)
treeb2b16d7cab5886de19288225e1ab90bfd25bee37 /Tests/CustomCommand/CMakeLists.txt
parentf0cdb6001b3e915fc0d9c1120165d49725440bbd (diff)
downloadCMake-4499d50ad2df7c1db4335d40f9fa20c642f59a5d.zip
CMake-4499d50ad2df7c1db4335d40f9fa20c642f59a5d.tar.gz
CMake-4499d50ad2df7c1db4335d40f9fa20c642f59a5d.tar.bz2
Mark CustomCommand test perconfig.out as SYMBOLIC
The custom command with this output does not actually create the file, so mark it as SYMBOLIC.
Diffstat (limited to 'Tests/CustomCommand/CMakeLists.txt')
-rw-r--r--Tests/CustomCommand/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/Tests/CustomCommand/CMakeLists.txt b/Tests/CustomCommand/CMakeLists.txt
index 450323e..6a86a34 100644
--- a/Tests/CustomCommand/CMakeLists.txt
+++ b/Tests/CustomCommand/CMakeLists.txt
@@ -432,6 +432,7 @@ ADD_CUSTOM_COMMAND(
DEPENDS ${PerConfig_DEPENDS}
VERBATIM
)
+SET_PROPERTY(SOURCE perconfig.out PROPERTY SYMBOLIC 1)
ADD_CUSTOM_TARGET(perconfig_target ALL
COMMAND ${CMAKE_COMMAND} -E echo "perconfig=$<TARGET_FILE:perconfig>" "config=$<CONFIGURATION>"
DEPENDS perconfig.out)