summaryrefslogtreecommitdiffstats
path: root/Tests/CustomCommand/CMakeLists.txt
diff options
context:
space:
mode:
authorRolf Eike Beer <eike@sf-mail.de>2014-04-06 19:51:33 (GMT)
committerRolf Eike Beer <eike@sf-mail.de>2014-04-14 16:17:05 (GMT)
commit5bd48ac5348885e15ebb23ea825a1ea777985b97 (patch)
tree340ac037fe081ef314cb12ecdfca2b229c2f4ea8 /Tests/CustomCommand/CMakeLists.txt
parent2622bc3f65162bf6d6cb5838da6999f8b5ca75cf (diff)
downloadCMake-5bd48ac5348885e15ebb23ea825a1ea777985b97.zip
CMake-5bd48ac5348885e15ebb23ea825a1ea777985b97.tar.gz
CMake-5bd48ac5348885e15ebb23ea825a1ea777985b97.tar.bz2
Replace string(REGEX REPLACE) with string(REPLACE) where possible
The simple replacement is much faster.
Diffstat (limited to 'Tests/CustomCommand/CMakeLists.txt')
-rw-r--r--Tests/CustomCommand/CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/Tests/CustomCommand/CMakeLists.txt b/Tests/CustomCommand/CMakeLists.txt
index a194a5f..e0854ce 100644
--- a/Tests/CustomCommand/CMakeLists.txt
+++ b/Tests/CustomCommand/CMakeLists.txt
@@ -367,8 +367,8 @@ endif()
foreach(arg ${CHECK_ARGS} "")
set(ARG "${arg}")
- string(REGEX REPLACE "\\\\" "\\\\\\\\" ARG "${ARG}")
- string(REGEX REPLACE "\"" "\\\\\"" ARG "${ARG}")
+ string(REPLACE "\\" "\\\\" ARG "${ARG}")
+ string(REPLACE "\"" "\\\"" ARG "${ARG}")
set(EXPECTED_ARGUMENTS
"${EXPECTED_ARGUMENTS} \"${ARG}\",
")