summaryrefslogtreecommitdiffstats
path: root/Tests/CustomCommand/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2007-12-18 14:50:08 (GMT)
committerBrad King <brad.king@kitware.com>2007-12-18 14:50:08 (GMT)
commit872553de7e729788242da37124f41e40228c6f13 (patch)
tree1bb9aaa4a3fa205c260f09b8eaa80efba79ec7ac /Tests/CustomCommand/CMakeLists.txt
parent42bad89fe7ba61bed1f0ba293e8497970df2cef0 (diff)
downloadCMake-872553de7e729788242da37124f41e40228c6f13.zip
CMake-872553de7e729788242da37124f41e40228c6f13.tar.gz
CMake-872553de7e729788242da37124f41e40228c6f13.tar.bz2
ENH: Implemented generation of display for pre-build, pre-link, and post-build custom command comments during the build. This addresses issue #5353.
Diffstat (limited to 'Tests/CustomCommand/CMakeLists.txt')
-rw-r--r--Tests/CustomCommand/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/Tests/CustomCommand/CMakeLists.txt b/Tests/CustomCommand/CMakeLists.txt
index 669fbb8..71ded6d 100644
--- a/Tests/CustomCommand/CMakeLists.txt
+++ b/Tests/CustomCommand/CMakeLists.txt
@@ -95,12 +95,14 @@ ADD_CUSTOM_COMMAND(
TARGET TDocument PRE_BUILD
COMMAND ${CMAKE_COMMAND} -E echo " Writing doc1pre.txt."
COMMAND ${CMAKE_COMMAND} -E copy ${PROJECT_SOURCE_DIR}/doc1.tex ${PROJECT_BINARY_DIR}/doc1pre.txt
+ COMMENT "Running TDocument pre-build commands"
)
ADD_CUSTOM_COMMAND(
TARGET TDocument POST_BUILD
COMMAND ${CMAKE_COMMAND} -E echo " Copying doc1pre.txt to doc2post.txt."
COMMAND ${CMAKE_COMMAND} -E copy ${PROJECT_BINARY_DIR}/doc1pre.txt
${PROJECT_BINARY_DIR}/doc2post.txt
+ COMMENT "Running TDocument post-build commands"
)
################################################################