summaryrefslogtreecommitdiffstats
path: root/Tests/CustomCommand/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2008-06-02 20:45:07 (GMT)
committerBrad King <brad.king@kitware.com>2008-06-02 20:45:07 (GMT)
commitbed3ac8741405132096430c9f61578df9f8cfbf9 (patch)
treeb140448aa518e2d4e20349cf5c72ce8e412a6977 /Tests/CustomCommand/CMakeLists.txt
parent6be09c366774ed6d723a06f5f07ba5c09d8e4579 (diff)
downloadCMake-bed3ac8741405132096430c9f61578df9f8cfbf9.zip
CMake-bed3ac8741405132096430c9f61578df9f8cfbf9.tar.gz
CMake-bed3ac8741405132096430c9f61578df9f8cfbf9.tar.bz2
ENH: Remove SKIP_RULE_DEPENDS option from add_custom_command()
- Option was recently added but never released. - Custom commands no longer depend on build.make so we do not need the option. - Rule hashes now take care of rebuilding when rules change so the dependency is not needed.
Diffstat (limited to 'Tests/CustomCommand/CMakeLists.txt')
-rw-r--r--Tests/CustomCommand/CMakeLists.txt8
1 files changed, 0 insertions, 8 deletions
diff --git a/Tests/CustomCommand/CMakeLists.txt b/Tests/CustomCommand/CMakeLists.txt
index 5ee0519..7e9f29c 100644
--- a/Tests/CustomCommand/CMakeLists.txt
+++ b/Tests/CustomCommand/CMakeLists.txt
@@ -151,14 +151,6 @@ ADD_EXECUTABLE(CustomCommand
${PROJECT_BINARY_DIR}/generated.c
${PROJECT_BINARY_DIR}/not_included.h
gen_redirect.c # default location for custom commands is in build tree
- gen_once.c
- )
-
-# Add a rule with no dependencies.
-ADD_CUSTOM_COMMAND(
- OUTPUT gen_once.c
- COMMAND ${CMAKE_COMMAND} -E copy ${PROJECT_SOURCE_DIR}/gen_once.c.in ${PROJECT_BINARY_DIR}/gen_once.c
- SKIP_RULE_DEPENDS
)
# Add the rule to create generated.c at build time. This is placed