summaryrefslogtreecommitdiffstats
path: root/Tests/Dependency/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2008-08-07 14:13:15 (GMT)
committerBrad King <brad.king@kitware.com>2008-08-07 14:13:15 (GMT)
commitc76f3ae5b5b9709fc2cd97d838e52c52412bf5c5 (patch)
tree28c704f174b5d826ef3a1427c00bdcb647ab0f4d /Tests/Dependency/CMakeLists.txt
parentb8fc8b324d2e1b892d0b41cf3581226c210131d0 (diff)
downloadCMake-c76f3ae5b5b9709fc2cd97d838e52c52412bf5c5.zip
CMake-c76f3ae5b5b9709fc2cd97d838e52c52412bf5c5.tar.gz
CMake-c76f3ae5b5b9709fc2cd97d838e52c52412bf5c5.tar.bz2
ENH: Test fake circular dependency case
A recent change fixed a case in which CMake incorrectly diagnosed a circular dependency involving a non-linkable executable target. This adds a test for that case.
Diffstat (limited to 'Tests/Dependency/CMakeLists.txt')
-rw-r--r--Tests/Dependency/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/Tests/Dependency/CMakeLists.txt b/Tests/Dependency/CMakeLists.txt
index d2c1c1a..d700374 100644
--- a/Tests/Dependency/CMakeLists.txt
+++ b/Tests/Dependency/CMakeLists.txt
@@ -52,3 +52,4 @@ ADD_SUBDIRECTORY(Exec4)
ADD_SUBDIRECTORY(Case1)
ADD_SUBDIRECTORY(Case2)
ADD_SUBDIRECTORY(Case3)
+ADD_SUBDIRECTORY(Case4)