summaryrefslogtreecommitdiffstats
path: root/Tests/FindGTest/CMakeLists.txt
diff options
context:
space:
mode:
authorRoger Leigh <rleigh@codelibre.net>2015-12-10 23:08:23 (GMT)
committerRoger Leigh <rleigh@codelibre.net>2015-12-10 23:09:16 (GMT)
commit99afe23513054db4add5143de4aa3a826e8c6c75 (patch)
treeefd88c253726469322db14953b0d9cc262400616 /Tests/FindGTest/CMakeLists.txt
parent611735e76e14807e2145d6b67efbb080d419f19f (diff)
downloadCMake-99afe23513054db4add5143de4aa3a826e8c6c75.zip
CMake-99afe23513054db4add5143de4aa3a826e8c6c75.tar.gz
CMake-99afe23513054db4add5143de4aa3a826e8c6c75.tar.bz2
Tests: Add tests for FindGTest
Diffstat (limited to 'Tests/FindGTest/CMakeLists.txt')
-rw-r--r--Tests/FindGTest/CMakeLists.txt10
1 files changed, 10 insertions, 0 deletions
diff --git a/Tests/FindGTest/CMakeLists.txt b/Tests/FindGTest/CMakeLists.txt
new file mode 100644
index 0000000..cbc92b1
--- /dev/null
+++ b/Tests/FindGTest/CMakeLists.txt
@@ -0,0 +1,10 @@
+add_test(NAME FindGTest.Test COMMAND
+ ${CMAKE_CTEST_COMMAND} -C $<CONFIGURATION>
+ --build-and-test
+ "${CMake_SOURCE_DIR}/Tests/FindGTest/Test"
+ "${CMake_BINARY_DIR}/Tests/FindGTest/Test"
+ ${build_generator_args}
+ --build-project TestFindGTest
+ --build-options ${build_options}
+ --test-command ${CMAKE_CTEST_COMMAND} -V -C $<CONFIGURATION>
+ )