summaryrefslogtreecommitdiffstats
path: root/Tests/FindPython/PyPy3/CMakeLists.txt
diff options
context:
space:
mode:
authorMarc Chevrier <marc.chevrier@gmail.com>2020-04-29 09:28:41 (GMT)
committerMarc Chevrier <marc.chevrier@gmail.com>2020-05-01 13:03:04 (GMT)
commitc1ef70d4d1e5b37fc6b6a1e14258ee8028ef2b05 (patch)
tree1fa87c4c3b81830adb100d5668baf7fdacf8da5e /Tests/FindPython/PyPy3/CMakeLists.txt
parent6556e587efa8ad954126137c6ca867f1f2797b11 (diff)
downloadCMake-c1ef70d4d1e5b37fc6b6a1e14258ee8028ef2b05.zip
CMake-c1ef70d4d1e5b37fc6b6a1e14258ee8028ef2b05.tar.gz
CMake-c1ef70d4d1e5b37fc6b6a1e14258ee8028ef2b05.tar.bz2
FindPython: Add support for 'PyPy'
Diffstat (limited to 'Tests/FindPython/PyPy3/CMakeLists.txt')
-rw-r--r--Tests/FindPython/PyPy3/CMakeLists.txt37
1 files changed, 37 insertions, 0 deletions
diff --git a/Tests/FindPython/PyPy3/CMakeLists.txt b/Tests/FindPython/PyPy3/CMakeLists.txt
new file mode 100644
index 0000000..5562d57
--- /dev/null
+++ b/Tests/FindPython/PyPy3/CMakeLists.txt
@@ -0,0 +1,37 @@
+cmake_minimum_required(VERSION 3.1)
+
+project(TestPyPy3 C)
+
+set (Python3_FIND_IMPLEMENTATIONS "PyPy")
+
+find_package(Python3 COMPONENTS Interpreter Development)
+if (NOT Python3_FOUND)
+ message (FATAL_ERROR "Fail to found Python PyPy 3")
+endif()
+
+if (NOT Python3_Interpreter_FOUND)
+ message (FATAL_ERROR "Fail to found Python PyPy 3 Interpreter")
+endif()
+if (NOT Python3_INTERPRETER_ID STREQUAL "PyPy")
+ message (FATAL_ERROR "Erroneous interpreter ID (${Python3_INTERPRETER_ID})")
+endif()
+
+if (NOT Python3_Development.Module_FOUND)
+ message (FATAL_ERROR "Fail to found Python PyPy 3 Development.Module")
+endif()
+if (NOT Python3_Development.Embed_FOUND)
+ message (FATAL_ERROR "Fail to found Python PyPy 3 Development.Embed")
+endif()
+if (NOT Python3_Development_FOUND)
+ message (FATAL_ERROR "Fail to found Python PyPy 3 Development")
+endif()
+
+if(NOT TARGET Python3::Interpreter)
+ message(SEND_ERROR "Python3::Interpreter not found")
+endif()
+if(NOT TARGET Python3::Module)
+ message(SEND_ERROR "Python3::Module not found")
+endif()
+if(NOT TARGET Python3::Python)
+ message(SEND_ERROR "Python3::Python not found")
+endif()