summaryrefslogtreecommitdiffstats
path: root/Tests/Fortran/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2015-07-06 14:21:25 (GMT)
committerBrad King <brad.king@kitware.com>2015-07-06 14:35:02 (GMT)
commit0a203db5dc4c654a488777acd785337dd24137e2 (patch)
treee4fe52c8888eb74495c2afaf550f851b7a16cf54 /Tests/Fortran/CMakeLists.txt
parenta6916a6c6e397bda8b381f65dbfc59d3c52f8525 (diff)
downloadCMake-0a203db5dc4c654a488777acd785337dd24137e2.zip
CMake-0a203db5dc4c654a488777acd785337dd24137e2.tar.gz
CMake-0a203db5dc4c654a488777acd785337dd24137e2.tar.bz2
Fortran: Fix passing of preprocessor definitions to dependency scanner
In commit v3.3.0-rc1~352^2~3 (Genex: Allow COMPILE_LANGUAGE when processing compile definitions, 2015-03-04) the name of the variable used to pass preprocessor definitions to the Fortran dependency scanner was changed to be per-language, but the actual dependency scanning code was not updated accordingly. Update the code and add a test case. Reported-by: Radovan Bast <radovan.bast@gmail.com>
Diffstat (limited to 'Tests/Fortran/CMakeLists.txt')
-rw-r--r--Tests/Fortran/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/Tests/Fortran/CMakeLists.txt b/Tests/Fortran/CMakeLists.txt
index 8700c94..753ce27 100644
--- a/Tests/Fortran/CMakeLists.txt
+++ b/Tests/Fortran/CMakeLists.txt
@@ -168,7 +168,7 @@ if(CMAKE_Fortran_COMPILER_SUPPORTS_F90)
add_definitions(-DFOO -DBAR=1)
include_directories(${testf_SOURCE_DIR}/include)
- add_executable(test_preprocess test_preprocess.F90)
+ add_executable(test_preprocess test_preprocess.F90 test_preprocess_module.F90)
set(TEST_MODULE_DEPENDS 1)
endif()