summaryrefslogtreecommitdiffstats
path: root/Tests/Fortran/Library/CMakeLists.txt
diff options
context:
space:
mode:
authorKitware Robot <kwrobot@kitware.com>2012-08-13 17:47:32 (GMT)
committerBrad King <brad.king@kitware.com>2012-08-13 18:19:16 (GMT)
commit77543bde41b0e52c3959016698b529835945d62d (patch)
treeff63e5fbec326c4a5d821e7496c6d2cb52f75b92 /Tests/Fortran/Library/CMakeLists.txt
parent7bbaa4283de26864b2e55e819db0884771585467 (diff)
downloadCMake-77543bde41b0e52c3959016698b529835945d62d.zip
CMake-77543bde41b0e52c3959016698b529835945d62d.tar.gz
CMake-77543bde41b0e52c3959016698b529835945d62d.tar.bz2
Convert CMake-language commands to lower case
Ancient CMake versions required upper-case commands. Later command names became case-insensitive. Now the preferred style is lower-case. Run the following shell code: cmake --help-command-list | grep -v "cmake version" | while read c; do echo 's/\b'"$(echo $c | tr '[:lower:]' '[:upper:]')"'\(\s*\)(/'"$c"'\1(/g' done >convert.sed && git ls-files -z -- bootstrap '*.cmake' '*.cmake.in' '*CMakeLists.txt' | egrep -z -v '^(Utilities/cm|Source/kwsys/)' | xargs -0 sed -i -f convert.sed && rm convert.sed
Diffstat (limited to 'Tests/Fortran/Library/CMakeLists.txt')
-rw-r--r--Tests/Fortran/Library/CMakeLists.txt14
1 files changed, 7 insertions, 7 deletions
diff --git a/Tests/Fortran/Library/CMakeLists.txt b/Tests/Fortran/Library/CMakeLists.txt
index fe1368a..6e39cda 100644
--- a/Tests/Fortran/Library/CMakeLists.txt
+++ b/Tests/Fortran/Library/CMakeLists.txt
@@ -1,11 +1,11 @@
-INCLUDE_DIRECTORIES(${Library_MODDIR})
-ADD_LIBRARY(subdir_mods a.f90 b.f90)
-ADD_EXECUTABLE(subdir_exe main.f90)
-TARGET_LINK_LIBRARIES(subdir_exe subdir_mods)
+include_directories(${Library_MODDIR})
+add_library(subdir_mods a.f90 b.f90)
+add_executable(subdir_exe main.f90)
+target_link_libraries(subdir_exe subdir_mods)
# Test module output directory if available.
-IF(CMAKE_Fortran_MODDIR_FLAG)
- SET_TARGET_PROPERTIES(subdir_mods PROPERTIES
+if(CMAKE_Fortran_MODDIR_FLAG)
+ set_target_properties(subdir_mods PROPERTIES
Fortran_MODULE_DIRECTORY modules
)
-ENDIF(CMAKE_Fortran_MODDIR_FLAG)
+endif(CMAKE_Fortran_MODDIR_FLAG)