summaryrefslogtreecommitdiffstats
path: root/Tests/Framework/CMakeLists.txt
diff options
context:
space:
mode:
authorDavid Cole <david.cole@kitware.com>2007-08-24 17:30:41 (GMT)
committerDavid Cole <david.cole@kitware.com>2007-08-24 17:30:41 (GMT)
commit9a4e7ea742e7ff8e1110f3fe55e98340cb309aef (patch)
tree1de0114f0f0f2fc3ac8ac9a2d92770a6e08ea281 /Tests/Framework/CMakeLists.txt
parent6d508a3094c31910728b24e13ceebbc3070b5e04 (diff)
downloadCMake-9a4e7ea742e7ff8e1110f3fe55e98340cb309aef.zip
CMake-9a4e7ea742e7ff8e1110f3fe55e98340cb309aef.tar.gz
CMake-9a4e7ea742e7ff8e1110f3fe55e98340cb309aef.tar.bz2
ENH: Add InstallNameFixupPath to support installing built frameworks on the Mac. Change Application to Applications in the BundleTest. Also correct small typo (tcl->Tcl) noted in bug 4572.
Diffstat (limited to 'Tests/Framework/CMakeLists.txt')
-rw-r--r--Tests/Framework/CMakeLists.txt5
1 files changed, 4 insertions, 1 deletions
diff --git a/Tests/Framework/CMakeLists.txt b/Tests/Framework/CMakeLists.txt
index f1f82cb..57028d7 100644
--- a/Tests/Framework/CMakeLists.txt
+++ b/Tests/Framework/CMakeLists.txt
@@ -27,7 +27,10 @@ set_source_files_properties(test.lua PROPERTIES
)
add_executable(bar bar.cxx)
target_link_libraries(bar foo)
-
+install(TARGETS foo bar
+ RUNTIME DESTINATION /Applications/CMakeTestsFramework/bin
+ FRAMEWORK DESTINATION /Library/Frameworks
+)
# Make a static library and apply the framework properties to it to verify
# that everything still builds correctly, but it will not actually produce