summaryrefslogtreecommitdiffstats
path: root/Tests/LinkLine/CMakeLists.txt
diff options
context:
space:
mode:
authorKitware Robot <kwrobot@kitware.com>2012-08-13 17:47:32 (GMT)
committerBrad King <brad.king@kitware.com>2012-08-13 18:19:16 (GMT)
commit77543bde41b0e52c3959016698b529835945d62d (patch)
treeff63e5fbec326c4a5d821e7496c6d2cb52f75b92 /Tests/LinkLine/CMakeLists.txt
parent7bbaa4283de26864b2e55e819db0884771585467 (diff)
downloadCMake-77543bde41b0e52c3959016698b529835945d62d.zip
CMake-77543bde41b0e52c3959016698b529835945d62d.tar.gz
CMake-77543bde41b0e52c3959016698b529835945d62d.tar.bz2
Convert CMake-language commands to lower case
Ancient CMake versions required upper-case commands. Later command names became case-insensitive. Now the preferred style is lower-case. Run the following shell code: cmake --help-command-list | grep -v "cmake version" | while read c; do echo 's/\b'"$(echo $c | tr '[:lower:]' '[:upper:]')"'\(\s*\)(/'"$c"'\1(/g' done >convert.sed && git ls-files -z -- bootstrap '*.cmake' '*.cmake.in' '*CMakeLists.txt' | egrep -z -v '^(Utilities/cm|Source/kwsys/)' | xargs -0 sed -i -f convert.sed && rm convert.sed
Diffstat (limited to 'Tests/LinkLine/CMakeLists.txt')
-rw-r--r--Tests/LinkLine/CMakeLists.txt12
1 files changed, 6 insertions, 6 deletions
diff --git a/Tests/LinkLine/CMakeLists.txt b/Tests/LinkLine/CMakeLists.txt
index c8f0ecf..6154dd4 100644
--- a/Tests/LinkLine/CMakeLists.txt
+++ b/Tests/LinkLine/CMakeLists.txt
@@ -1,12 +1,12 @@
-PROJECT( LinkLine )
+project( LinkLine )
# Makes sure that the library order as specified by the user are
# unchanged by dependency analysis, etc. libOne and libTwo are
# dependent on each other. The link line should be -lOne -lTwo -lOne.
-ADD_LIBRARY( One One.c )
-ADD_LIBRARY( Two Two.c )
+add_library( One One.c )
+add_library( Two Two.c )
-LINK_LIBRARIES( One Two )
-ADD_EXECUTABLE( LinkLine Exec.c )
-LINK_LIBRARIES( One )
+link_libraries( One Two )
+add_executable( LinkLine Exec.c )
+link_libraries( One )