summaryrefslogtreecommitdiffstats
path: root/Tests/MacRuntimePath/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2014-09-05 19:40:01 (GMT)
committerBrad King <brad.king@kitware.com>2014-09-10 15:21:50 (GMT)
commit09ab207c668deadea3635a20812fa2f478c17f9f (patch)
tree7c3bdee26a650942d2659573d523752daa1e964a /Tests/MacRuntimePath/CMakeLists.txt
parent6944997bd6aa69fdf88f8e4e154e68d57195b20b (diff)
downloadCMake-09ab207c668deadea3635a20812fa2f478c17f9f.zip
CMake-09ab207c668deadea3635a20812fa2f478c17f9f.tar.gz
CMake-09ab207c668deadea3635a20812fa2f478c17f9f.tar.bz2
Tests: Add generator platform support
Propagate CMAKE_GENERATOR_PLATFORM through the test hierarchy so that all tests can build with the selected generator platform, if any.
Diffstat (limited to 'Tests/MacRuntimePath/CMakeLists.txt')
-rw-r--r--Tests/MacRuntimePath/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/Tests/MacRuntimePath/CMakeLists.txt b/Tests/MacRuntimePath/CMakeLists.txt
index eeb3653..3e9ab8a 100644
--- a/Tests/MacRuntimePath/CMakeLists.txt
+++ b/Tests/MacRuntimePath/CMakeLists.txt
@@ -39,6 +39,7 @@ add_custom_command(
--build-project MacRuntimePath_A
--build-target install
--build-generator ${CMAKE_GENERATOR}
+ --build-generator-platform "${CMAKE_GENERATOR_PLATFORM}"
--build-generator-toolset "${CMAKE_GENERATOR_TOOLSET}"
--build-options -C${MacRuntimePath_BINARY_DIR}/InitialCache.cmake
VERBATIM
@@ -60,6 +61,7 @@ add_custom_command(
--build-noclean
--build-project MacRuntimePath_B
--build-generator ${CMAKE_GENERATOR}
+ --build-generator-platform "${CMAKE_GENERATOR_PLATFORM}"
--build-generator-toolset "${CMAKE_GENERATOR_TOOLSET}"
--build-options -C${MacRuntimePath_BINARY_DIR}/InitialCache.cmake
VERBATIM