summaryrefslogtreecommitdiffstats
path: root/Tests/MakeClean/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2009-07-08 15:41:48 (GMT)
committerBrad King <brad.king@kitware.com>2009-07-08 15:41:48 (GMT)
commitd1aa17a7b0f3b81367d4eb10e2404a5214f6890a (patch)
tree9402693c7ff8ea4f7c611fb59d69d5c5a953793a /Tests/MakeClean/CMakeLists.txt
parenta30a41e5ca07a278dbea87fd7d6085e1f6bf9714 (diff)
downloadCMake-d1aa17a7b0f3b81367d4eb10e2404a5214f6890a.zip
CMake-d1aa17a7b0f3b81367d4eb10e2404a5214f6890a.tar.gz
CMake-d1aa17a7b0f3b81367d4eb10e2404a5214f6890a.tar.bz2
ENH: Remove CMAKE_ANSI_CFLAGS from tests
As of CMake 2.6 this variable is not defined, and the ANSI flags for the HP compiler are simply hard-coded in the default C flags.
Diffstat (limited to 'Tests/MakeClean/CMakeLists.txt')
-rw-r--r--Tests/MakeClean/CMakeLists.txt7
1 files changed, 0 insertions, 7 deletions
diff --git a/Tests/MakeClean/CMakeLists.txt b/Tests/MakeClean/CMakeLists.txt
index aaf39d7..97d3554 100644
--- a/Tests/MakeClean/CMakeLists.txt
+++ b/Tests/MakeClean/CMakeLists.txt
@@ -1,8 +1,6 @@
cmake_minimum_required (VERSION 2.6)
PROJECT(MakeClean)
-SET(CMAKE_C_FLAGS "${CMAKE_ANSI_CFLAGS} ${CMAKE_C_FLAGS}")
-
# Build the to-clean project.
TRY_COMPILE(TOCLEAN_BUILT
${MakeClean_BINARY_DIR}/ToClean
@@ -33,11 +31,6 @@ FOREACH(f ${TOCLEAN_FILES})
ENDIF(EXISTS "${f}")
ENDFOREACH(f)
-# Enable ANSI flags for the C executable.
-IF(CMAKE_ANSI_CFLAGS)
- SET(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} ${CMAKE_ANSI_CFLAGS}")
-ENDIF(CMAKE_ANSI_CFLAGS)
-
# Configure an executable to check that all the files are missing.
SET(CHECK_FILES)
FOREACH(f ${TOCLEAN_FILES})