summaryrefslogtreecommitdiffstats
path: root/Tests/Plugin/CMakeLists.txt
diff options
context:
space:
mode:
authorRolf Eike Beer <eike@sf-mail.de>2021-04-04 20:57:58 (GMT)
committerBrad King <brad.king@kitware.com>2021-04-05 13:53:07 (GMT)
commitf6b4db365a5e5723029c06357e81aa6c93ba1f76 (patch)
treed6f5dff9b8a3036cc8ec6b9221c3d7bbf1dde6be /Tests/Plugin/CMakeLists.txt
parent20e90c08e3b1fa60b69442d384bcc236ff6f8a21 (diff)
downloadCMake-f6b4db365a5e5723029c06357e81aa6c93ba1f76.zip
CMake-f6b4db365a5e5723029c06357e81aa6c93ba1f76.tar.gz
CMake-f6b4db365a5e5723029c06357e81aa6c93ba1f76.tar.bz2
Tests: bump cmake_minimum_required version to 2.8.12
This needlessly produces warnings during the test runs that no-one sees but that are distracting when actually inspecting the logs.
Diffstat (limited to 'Tests/Plugin/CMakeLists.txt')
-rw-r--r--Tests/Plugin/CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/Tests/Plugin/CMakeLists.txt b/Tests/Plugin/CMakeLists.txt
index 729bba3..ec22bf4 100644
--- a/Tests/Plugin/CMakeLists.txt
+++ b/Tests/Plugin/CMakeLists.txt
@@ -1,4 +1,4 @@
-cmake_minimum_required (VERSION 2.6)
+cmake_minimum_required (VERSION 2.8.12)
cmake_policy(SET CMP0054 NEW)
project(Plugin)
@@ -46,7 +46,7 @@ target_link_libraries(example_mod_1 example_exe)
if(CMAKE_SHARED_LIBRARY_SONAME_C_FLAG AND
"${CMAKE_C_CREATE_SHARED_MODULE}" MATCHES "SONAME_FLAG")
# Verify that targets export with proper IMPORTED SONAME properties.
- export(TARGETS example_mod_1 NAMESPACE exp_
+ export(TARGETS example_mod_1 example_exe NAMESPACE exp_
FILE ${CMAKE_CURRENT_BINARY_DIR}/mods.cmake)
include(ExternalProject)