summaryrefslogtreecommitdiffstats
path: root/Tests/QtAutomoc/CMakeLists.txt
diff options
context:
space:
mode:
authorAlex Neundorf <neundorf@kde.org>2011-08-16 00:10:45 (GMT)
committerAlex Neundorf <neundorf@kde.org>2011-08-16 00:13:26 (GMT)
commitbf8ef778a317fd7cd82bcc658fc734bf3f29911e (patch)
tree84ee95d0e1c68330d4cff412e599c8969636bfc8 /Tests/QtAutomoc/CMakeLists.txt
parentd045fd4ec5d88658988c8878b313b2bf7924f40f (diff)
downloadCMake-bf8ef778a317fd7cd82bcc658fc734bf3f29911e.zip
CMake-bf8ef778a317fd7cd82bcc658fc734bf3f29911e.tar.gz
CMake-bf8ef778a317fd7cd82bcc658fc734bf3f29911e.tar.bz2
Add a test for automoc
The files are taken from the Qt examples. They are BSD licensed, so it should be fine. I only edited main.cpp to use both widgets. Alex
Diffstat (limited to 'Tests/QtAutomoc/CMakeLists.txt')
-rw-r--r--Tests/QtAutomoc/CMakeLists.txt20
1 files changed, 20 insertions, 0 deletions
diff --git a/Tests/QtAutomoc/CMakeLists.txt b/Tests/QtAutomoc/CMakeLists.txt
new file mode 100644
index 0000000..4a5ff10
--- /dev/null
+++ b/Tests/QtAutomoc/CMakeLists.txt
@@ -0,0 +1,20 @@
+cmake_minimum_required(VERSION 2.8)
+
+project(QtAutomoc)
+
+find_package(Qt4 REQUIRED)
+
+include(UseQt4)
+
+include_directories(${CMAKE_CURRENT_BINARY_DIR})
+
+add_definitions(-DFOO)
+
+# create an executable and a library target, both requiring automoc:
+add_library(codeeditorLib STATIC codeeditor.cpp)
+
+add_executable(foo main.cpp calwidget.cpp )
+
+set_target_properties(foo codeeditorLib PROPERTIES AUTOMOC TRUE)
+
+target_link_libraries(foo codeeditorLib ${QT_LIBRARIES} )