summaryrefslogtreecommitdiffstats
path: root/Tests/RunCMake/CMakeLists.txt
diff options
context:
space:
mode:
authorGregor Jasny <gjasny@googlemail.com>2015-02-22 18:00:11 (GMT)
committerBrad King <brad.king@kitware.com>2015-02-23 18:10:52 (GMT)
commit0ee2a004e70e2d49423f5b4b393896258e8ab688 (patch)
tree6e7abdef78dce1d5557fa049b933149686a8198d /Tests/RunCMake/CMakeLists.txt
parentcb16c7844dce627ab40f404c6ac49db3cde7b0c0 (diff)
downloadCMake-0ee2a004e70e2d49423f5b4b393896258e8ab688.zip
CMake-0ee2a004e70e2d49423f5b4b393896258e8ab688.tar.gz
CMake-0ee2a004e70e2d49423f5b4b393896258e8ab688.tar.bz2
OS X: Add platform-specific Frameworks search path
Otherwise find_library is unable to lookup the XCTest framework which is not located in the SDK serach path: In the 10.10 SDK the SDK frameworks are located here: $DEVELOPER_DIR/Platforms/MacOSX.platform/Developer/SDKs/MacOSX10.10.sdk/System/Library/Frameworks whereas the Platform SDKs are located here: $DEVELOPER_DIR/Platforms/MacOSX.platform/Developer/Library/Frameworks Signed-off-by: Gregor Jasny <gjasny@googlemail.com>
Diffstat (limited to 'Tests/RunCMake/CMakeLists.txt')
-rw-r--r--Tests/RunCMake/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/Tests/RunCMake/CMakeLists.txt b/Tests/RunCMake/CMakeLists.txt
index fd01201..6663b88 100644
--- a/Tests/RunCMake/CMakeLists.txt
+++ b/Tests/RunCMake/CMakeLists.txt
@@ -176,7 +176,7 @@ if("${CMAKE_GENERATOR}" MATCHES "Visual Studio [^6]")
endif()
if(XCODE_VERSION AND NOT "${XCODE_VERSION}" VERSION_LESS 3)
- add_RunCMake_test(XcodeProject)
+ add_RunCMake_test(XcodeProject -DXCODE_VERSION=${XCODE_VERSION})
endif()
add_RunCMake_test(File_Generate)