summaryrefslogtreecommitdiffstats
path: root/Tests/RunCMake/CMakeLists.txt
diff options
context:
space:
mode:
authorFabian Otto <fabian.otto@rohde-schwarz.com>2016-02-25 21:04:05 (GMT)
committerBrad King <brad.king@kitware.com>2016-02-26 15:52:13 (GMT)
commit6122909c33bea1256867a40a09e0eafa569e8c8b (patch)
treef47eba39b8d9cd9cb8c522f44c32807e9ad13c57 /Tests/RunCMake/CMakeLists.txt
parent6b0a664c1639b19ccc652a4be5f9824d0bf88e48 (diff)
downloadCMake-6122909c33bea1256867a40a09e0eafa569e8c8b.zip
CMake-6122909c33bea1256867a40a09e0eafa569e8c8b.tar.gz
CMake-6122909c33bea1256867a40a09e0eafa569e8c8b.tar.bz2
VS: Add option to set `ConfigurationType` of a .vcxproj file
Add a VS_CONFIGURATION_TYPE target property to set this value explicitly. This is useful to build a Windows Kernel Mode Driver, for example.
Diffstat (limited to 'Tests/RunCMake/CMakeLists.txt')
-rw-r--r--Tests/RunCMake/CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/Tests/RunCMake/CMakeLists.txt b/Tests/RunCMake/CMakeLists.txt
index 0a388c5..5bef629 100644
--- a/Tests/RunCMake/CMakeLists.txt
+++ b/Tests/RunCMake/CMakeLists.txt
@@ -236,6 +236,10 @@ if("${CMAKE_GENERATOR}" MATCHES "Visual Studio [^6]")
add_RunCMake_test(SolutionGlobalSections)
endif()
+if("${CMAKE_GENERATOR}" MATCHES "Visual Studio ([^6789]|[6789][0-9])")
+ add_RunCMake_test(VS10Project)
+endif()
+
if(XCODE_VERSION AND NOT "${XCODE_VERSION}" VERSION_LESS 3)
add_RunCMake_test(XcodeProject -DXCODE_VERSION=${XCODE_VERSION})
endif()