summaryrefslogtreecommitdiffstats
path: root/Tests/RunCMake/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2023-11-13 14:51:31 (GMT)
committerKitware Robot <kwrobot@kitware.com>2023-11-13 14:51:51 (GMT)
commitaf2fb376a41b47e19bf5effe1adad7bdc0ffd4e7 (patch)
treeb53c33bdba42bca73f8d536755cc1255e9d29385 /Tests/RunCMake/CMakeLists.txt
parent5bad0caea066cbea3698e4dcca16222215a2007f (diff)
parent7b99c42e57b11afe818827ac537ca020c020addd (diff)
downloadCMake-af2fb376a41b47e19bf5effe1adad7bdc0ffd4e7.zip
CMake-af2fb376a41b47e19bf5effe1adad7bdc0ffd4e7.tar.gz
CMake-af2fb376a41b47e19bf5effe1adad7bdc0ffd4e7.tar.bz2
Merge topic 'link-deduplicate-libs'
7b99c42e57 Link step: Enable to configure deduplication of libraries 07501c1678 Link Step: Introduce EntriesProcessing class Acked-by: Kitware Robot <kwrobot@kitware.com> Tested-by: buildbot <buildbot@kitware.com> Acked-by: scivision <michael@scivision.dev> Merge-request: !8946
Diffstat (limited to 'Tests/RunCMake/CMakeLists.txt')
-rw-r--r--Tests/RunCMake/CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/Tests/RunCMake/CMakeLists.txt b/Tests/RunCMake/CMakeLists.txt
index 2781f31..c3ef9a9 100644
--- a/Tests/RunCMake/CMakeLists.txt
+++ b/Tests/RunCMake/CMakeLists.txt
@@ -170,6 +170,8 @@ if(NOT WIN32 OR CYGWIN)
endif()
add_RunCMake_test(CMP0153)
+add_RunCMake_test(CMP0156 -DCMAKE_C_COMPILER_ID=${CMAKE_C_COMPILER_ID}
+ -DCMAKE_C_COMPILER_VERSION=${CMAKE_C_COMPILER_VERSION})
# The test for Policy 65 requires the use of the
# CMAKE_SHARED_LIBRARY_LINK_CXX_FLAGS variable, which both the VS and Xcode
@@ -748,6 +750,7 @@ if (CMAKE_SYSTEM_NAME MATCHES "(Linux|Darwin|Windows)"
-DCMAKE_C_COMPILER_VERSION=${CMAKE_C_COMPILER_VERSION})
endif()
+add_RunCMake_test(LinkLibrariesProcessing)
add_RunCMake_test(File_Archive)
add_RunCMake_test(File_Configure)
add_RunCMake_test(File_Generate)