summaryrefslogtreecommitdiffstats
path: root/Tests/RunCMake/get_filename_component/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2013-04-16 13:27:51 (GMT)
committerBrad King <brad.king@kitware.com>2013-04-16 13:35:29 (GMT)
commitec1ba9b0ae27a5731b98fecab648fa3edcfcffa2 (patch)
tree92bf0ea6452a8f76035dc75ecf3972e0934c8a01 /Tests/RunCMake/get_filename_component/CMakeLists.txt
parentdf71f968cd269854ab15147b012b6f07b1da6109 (diff)
downloadCMake-ec1ba9b0ae27a5731b98fecab648fa3edcfcffa2.zip
CMake-ec1ba9b0ae27a5731b98fecab648fa3edcfcffa2.tar.gz
CMake-ec1ba9b0ae27a5731b98fecab648fa3edcfcffa2.tar.bz2
get_filename_component: Add explicit unit tests
Add test RunCMake.get_filename_component to cover cases of the command. Remove redundant coverage of these cases from the "complex" tests.
Diffstat (limited to 'Tests/RunCMake/get_filename_component/CMakeLists.txt')
-rw-r--r--Tests/RunCMake/get_filename_component/CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/Tests/RunCMake/get_filename_component/CMakeLists.txt b/Tests/RunCMake/get_filename_component/CMakeLists.txt
new file mode 100644
index 0000000..e8db6b0
--- /dev/null
+++ b/Tests/RunCMake/get_filename_component/CMakeLists.txt
@@ -0,0 +1,3 @@
+cmake_minimum_required(VERSION 2.8)
+project(${RunCMake_TEST} NONE)
+include(${RunCMake_TEST}.cmake)