summaryrefslogtreecommitdiffstats
path: root/Tests/Server/CMakeLists.txt
diff options
context:
space:
mode:
authorTobias Hunger <tobias.hunger@qt.io>2016-09-27 19:29:20 (GMT)
committerTobias Hunger <tobias.hunger@qt.io>2016-09-28 18:10:59 (GMT)
commit71a505870c1f5a4fc89a8ad4e4dc3bb008a35118 (patch)
treecbef01144873d1a80bd96344d20c52d48dbcb654 /Tests/Server/CMakeLists.txt
parent7b1e60f26e284e223be8638744ba3a3b0efdee63 (diff)
downloadCMake-71a505870c1f5a4fc89a8ad4e4dc3bb008a35118.zip
CMake-71a505870c1f5a4fc89a8ad4e4dc3bb008a35118.tar.gz
CMake-71a505870c1f5a4fc89a8ad4e4dc3bb008a35118.tar.bz2
server-mode: Add project data for unit tests
Do some basic unit tests for "codemodel", "cmakeInputs" and "cache" commands of the cmake server. This just calls the commands right now and makes sure the server thinks it can reply to the request. The data itself is currently not validated.
Diffstat (limited to 'Tests/Server/CMakeLists.txt')
-rw-r--r--Tests/Server/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/Tests/Server/CMakeLists.txt b/Tests/Server/CMakeLists.txt
index 03f5042..8913406 100644
--- a/Tests/Server/CMakeLists.txt
+++ b/Tests/Server/CMakeLists.txt
@@ -10,6 +10,7 @@ macro(do_test bsname file)
"${CMAKE_SOURCE_DIR}/${file}"
"${CMAKE_SOURCE_DIR}"
"${CMAKE_BINARY_DIR}"
+ "${CMAKE_GENERATOR}"
RESULT_VARIABLE test_result
)
@@ -20,5 +21,6 @@ endmacro()
do_test("test_handshake" "tc_handshake.json")
do_test("test_globalSettings" "tc_globalSettings.json")
+do_test("test_buildsystem1" "tc_buildsystem1.json")
add_executable(Server empty.cpp)