summaryrefslogtreecommitdiffstats
path: root/Tests/SimpleInstallS2/CMakeLists.txt
diff options
context:
space:
mode:
authorAndy Cedilnik <andy.cedilnik@kitware.com>2004-02-11 13:28:59 (GMT)
committerAndy Cedilnik <andy.cedilnik@kitware.com>2004-02-11 13:28:59 (GMT)
commitff6bc566163ef85f4540240e933b47c47df481e1 (patch)
treeef18e1ae1f3f393d58fe7a56ef7d6bc79a7ba4ae /Tests/SimpleInstallS2/CMakeLists.txt
parenteaf25c6739a3d5c82d4e4e2059ed12a745560ec0 (diff)
downloadCMake-ff6bc566163ef85f4540240e933b47c47df481e1.zip
CMake-ff6bc566163ef85f4540240e933b47c47df481e1.tar.gz
CMake-ff6bc566163ef85f4540240e933b47c47df481e1.tar.bz2
ENH: On Cygwin shared libraries have only .dll file no .lib file, so when finding library on cygwin, search also for .dll. Also fix SimpleInstall test on cygwin
Diffstat (limited to 'Tests/SimpleInstallS2/CMakeLists.txt')
-rw-r--r--Tests/SimpleInstallS2/CMakeLists.txt16
1 files changed, 12 insertions, 4 deletions
diff --git a/Tests/SimpleInstallS2/CMakeLists.txt b/Tests/SimpleInstallS2/CMakeLists.txt
index 5582e44..e601af4 100644
--- a/Tests/SimpleInstallS2/CMakeLists.txt
+++ b/Tests/SimpleInstallS2/CMakeLists.txt
@@ -27,13 +27,21 @@ ENDIF(CMAKE_GENERATOR MATCHES "^Visual Studio")
MESSAGE("Extra install: ${EXTRA_INSTALL_FLAGS}")
IF(STAGE2)
+ SET(LIBPATHS "${CMAKE_INSTALL_PREFIX}/lib")
+ SET(t1NAMES test1 test1${CMAKE_DEBUG_POSTFIX})
+ SET(t2NAMES test2 test2${CMAKE_DEBUG_POSTFIX})
+
+ IF(WIN32 AND UNIX)
+ SET(LIBPATHS ${LIBPATHS} "${CMAKE_INSTALL_PREFIX}/bin")
+ ENDIF(WIN32 AND UNIX)
+ MESSAGE("Search for library in: ${LIBPATHS}")
FIND_LIBRARY(TEST1_LIBRARY
- NAMES test1 test1${CMAKE_DEBUG_POSTFIX}
- PATHS "${CMAKE_INSTALL_PREFIX}/lib"
+ NAMES ${t1NAMES}
+ PATHS ${LIBPATHS}
DOC "First library")
FIND_LIBRARY(TEST2_LIBRARY
- NAMES test2 test2${CMAKE_DEBUG_POSTFIX}
- PATHS "${CMAKE_INSTALL_PREFIX}/lib"
+ NAMES ${t2NAMES}
+ PATHS ${LIBPATHS}
DOC "First library")
ADD_EXECUTABLE (SimpleInstallS2 inst.cxx foo.c foo.h)