summaryrefslogtreecommitdiffstats
path: root/Tests/SubDir/CMakeLists.txt
diff options
context:
space:
mode:
authorKitware Robot <kwrobot@kitware.com>2012-08-13 17:42:58 (GMT)
committerBrad King <brad.king@kitware.com>2012-08-13 18:18:39 (GMT)
commit7bbaa4283de26864b2e55e819db0884771585467 (patch)
treeecb748dbe41a13d8bdea77acd0049cde999d933e /Tests/SubDir/CMakeLists.txt
parentbe9db98946b7918f279812fd0616abb650eebed0 (diff)
downloadCMake-7bbaa4283de26864b2e55e819db0884771585467.zip
CMake-7bbaa4283de26864b2e55e819db0884771585467.tar.gz
CMake-7bbaa4283de26864b2e55e819db0884771585467.tar.bz2
Remove trailing whitespace from most CMake and C/C++ code
Our Git commit hooks disallow modification or addition of lines with trailing whitespace. Wipe out all remnants of trailing whitespace everywhere except third-party code. Run the following shell code: git ls-files -z -- \ bootstrap doxygen.config '*.readme' \ '*.c' '*.cmake' '*.cpp' '*.cxx' \ '*.el' '*.f' '*.f90' '*.h' '*.in' '*.in.l' '*.java' \ '*.mm' '*.pike' '*.py' '*.txt' '*.vim' | egrep -z -v '^(Utilities/cm|Source/(kwsys|CursesDialog/form)/)' | egrep -z -v '^(Modules/CPack\..*\.in)' | xargs -0 sed -i 's/ \+$//'
Diffstat (limited to 'Tests/SubDir/CMakeLists.txt')
-rw-r--r--Tests/SubDir/CMakeLists.txt10
1 files changed, 5 insertions, 5 deletions
diff --git a/Tests/SubDir/CMakeLists.txt b/Tests/SubDir/CMakeLists.txt
index 9cfbe25..cf8fe97 100644
--- a/Tests/SubDir/CMakeLists.txt
+++ b/Tests/SubDir/CMakeLists.txt
@@ -4,11 +4,11 @@ SUBDIRS(Executable EXCLUDE_FROM_ALL Examples)
WRITE_FILE(${SUBDIR_BINARY_DIR}/ShouldBeHere "This file should exist.")
#WATCOM WMAKE does not support + in the name of a file!
IF(WATCOM)
- SET(PLUS_NAME_FILES
+ SET(PLUS_NAME_FILES
AnotherSubdir/pair_int.int.c
vcl_algorithm_vcl_pair_double.foo.c)
ELSE(WATCOM)
- SET(PLUS_NAME_FILES
+ SET(PLUS_NAME_FILES
AnotherSubdir/pair+int.int.c
vcl_algorithm+vcl_pair+double.foo.c)
ENDIF(WATCOM)
@@ -28,7 +28,7 @@ IF(WATCOM)
ENDIF("${f}" STREQUAL "ThirdSubDir/pair+int.int1.c")
ENDFOREACH(f)
SET(SOURCES ${SOURCES2})
- SET(SOURCES ${SOURCES}
+ SET(SOURCES ${SOURCES}
vcl_algorithm_vcl_pair_double.foo.c)
ELSE(WATCOM)
FOREACH(f ${SOURCES})
@@ -39,8 +39,8 @@ ELSE(WATCOM)
ENDIF("${f}" STREQUAL "ThirdSubDir/pair_int.int1.c")
ENDFOREACH(f)
SET(SOURCES ${SOURCES2})
- SET(SOURCES ${SOURCES}
+ SET(SOURCES ${SOURCES}
vcl_algorithm+vcl_pair+double.foo.c)
-ENDIF(WATCOM)
+ENDIF(WATCOM)
MESSAGE("Sources: ${SOURCES}")
ADD_EXECUTABLE(TestWithAuxSourceDir ${SOURCES})