summaryrefslogtreecommitdiffstats
path: root/Tests/SwiftOnly/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2021-07-21 14:44:15 (GMT)
committerBrad King <brad.king@kitware.com>2021-07-21 15:37:45 (GMT)
commit078ba4b2a47bee6575497b29c98fbbc4dc7d4dc8 (patch)
treeba3494852182de5a06803952d4bc9b12992ccdd0 /Tests/SwiftOnly/CMakeLists.txt
parente98bfa484f0e36a064fd83fc290751960a9facdd (diff)
downloadCMake-078ba4b2a47bee6575497b29c98fbbc4dc7d4dc8.zip
CMake-078ba4b2a47bee6575497b29c98fbbc4dc7d4dc8.tar.gz
CMake-078ba4b2a47bee6575497b29c98fbbc4dc7d4dc8.tar.bz2
Swift: Update test case to try CMP0126 NEW behavior
Extend the `SwiftOnly` test to cover the fix in commit 3ddd7f3576 (enable_language: Fix test for working compiler with CMP0126 NEW behavior, 2021-07-15), as that commit did for the `CSharpOnly` test. Fixes: #22451
Diffstat (limited to 'Tests/SwiftOnly/CMakeLists.txt')
-rw-r--r--Tests/SwiftOnly/CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/Tests/SwiftOnly/CMakeLists.txt b/Tests/SwiftOnly/CMakeLists.txt
index 41d14ea..01c2222 100644
--- a/Tests/SwiftOnly/CMakeLists.txt
+++ b/Tests/SwiftOnly/CMakeLists.txt
@@ -1,4 +1,7 @@
cmake_minimum_required(VERSION 3.3)
+if(POLICY CMP0126)
+ cmake_policy(SET CMP0126 NEW)
+endif()
# NOTE: Force the Release mode configuration as there are some issues with the
# debug information handling on macOS on certain Xcode builds.