summaryrefslogtreecommitdiffstats
path: root/Tests/SwiftOnly/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2015-07-06 20:15:49 (GMT)
committerBrad King <brad.king@kitware.com>2015-07-06 20:15:49 (GMT)
commitbf11253163b54f7c18b001cb00973a6341ee859b (patch)
treeadf50cd777722e5c08168025889c08a2e7ce68da /Tests/SwiftOnly/CMakeLists.txt
parent8fbd9584af44100bbddd0f4031b57c5bc2530837 (diff)
downloadCMake-bf11253163b54f7c18b001cb00973a6341ee859b.zip
CMake-bf11253163b54f7c18b001cb00973a6341ee859b.tar.gz
CMake-bf11253163b54f7c18b001cb00973a6341ee859b.tar.bz2
Add rudimentary support for the Apple Swift language with Xcode
Allow the `Swift` language to be enabled with the Xcode generator for Xcode >= 6.1. Reject it on other generators and with older Xcode versions. Since Apple is the only vendor implementing the language right now, the compiler id can be just `Apple`.
Diffstat (limited to 'Tests/SwiftOnly/CMakeLists.txt')
-rw-r--r--Tests/SwiftOnly/CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/Tests/SwiftOnly/CMakeLists.txt b/Tests/SwiftOnly/CMakeLists.txt
new file mode 100644
index 0000000..5cb9739
--- /dev/null
+++ b/Tests/SwiftOnly/CMakeLists.txt
@@ -0,0 +1,4 @@
+cmake_minimum_required(VERSION 3.3)
+project(SwiftOnly Swift)
+
+add_executable(SwiftOnly main.swift)