summaryrefslogtreecommitdiffstats
path: root/Tests/Tutorial/Step2/CMakeLists.txt
diff options
context:
space:
mode:
authorKen Martin <ken.martin@kitware.com>2005-11-09 21:21:05 (GMT)
committerKen Martin <ken.martin@kitware.com>2005-11-09 21:21:05 (GMT)
commitcf3116872673493859130699e5c42f8ba2775f50 (patch)
treee2c7de433bd755cc7b5833203379e46874bf3322 /Tests/Tutorial/Step2/CMakeLists.txt
parent4245eb0b53559f643f044b49ad31121e9c38298b (diff)
downloadCMake-cf3116872673493859130699e5c42f8ba2775f50.zip
CMake-cf3116872673493859130699e5c42f8ba2775f50.tar.gz
CMake-cf3116872673493859130699e5c42f8ba2775f50.tar.bz2
ENH: checkeed in step 1 and 2
Diffstat (limited to 'Tests/Tutorial/Step2/CMakeLists.txt')
-rw-r--r--Tests/Tutorial/Step2/CMakeLists.txt30
1 files changed, 30 insertions, 0 deletions
diff --git a/Tests/Tutorial/Step2/CMakeLists.txt b/Tests/Tutorial/Step2/CMakeLists.txt
new file mode 100644
index 0000000..7f12051
--- /dev/null
+++ b/Tests/Tutorial/Step2/CMakeLists.txt
@@ -0,0 +1,30 @@
+project (Tutorial)
+
+# The version number.
+set (Tutorial_VERSION_MAJOR 1)
+set (Tutorial_VERSION_MINOR 0)
+
+# configure a header file to pass some of the CMake settings
+# to the source code
+configure_file (
+ "${PROJECT_SOURCE_DIR}/TutorialConfig.h.in"
+ "${PROJECT_BINARY_DIR}/TutorialConfig.h"
+ )
+
+# should we use our own math functions
+option(USE_MYMATH "Use tutorial provided math implementation" ON)
+
+# add the binary tree to the search path for include files
+# so that we will find TutorialConfig.h
+include_directories ("${PROJECT_BINARY_DIR}")
+
+# add the MathFunctions library?
+if (USE_MYMATH)
+ include_directories ("${PROJECT_SOURCE_DIR}/MathFunctions")
+ add_subdirectory (MathFunctions)
+ set (EXTRA_LIBS ${EXTRA_LIBS} MathFunctions)
+endif (USE_MYMATH)
+
+# add the executable
+add_executable (Tutorial tutorial.cxx)
+target_link_libraries (Tutorial ${EXTRA_LIBS})