summaryrefslogtreecommitdiffstats
path: root/Tests/VSMASM/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2014-08-07 18:53:57 (GMT)
committerBrad King <brad.king@kitware.com>2014-08-20 14:19:49 (GMT)
commitdf3b007d7f904f8de5877f3e05b629239af7220a (patch)
treebf0f6ea804beac70c0a41cf1647d90f16820f311 /Tests/VSMASM/CMakeLists.txt
parente872744990f48777a1f1cebc791911363515092d (diff)
downloadCMake-df3b007d7f904f8de5877f3e05b629239af7220a.zip
CMake-df3b007d7f904f8de5877f3e05b629239af7220a.tar.gz
CMake-df3b007d7f904f8de5877f3e05b629239af7220a.tar.bz2
VS: Add test for MASM support
It is now expected to work with VS >= 10 and MSVC >= 13.1.
Diffstat (limited to 'Tests/VSMASM/CMakeLists.txt')
-rw-r--r--Tests/VSMASM/CMakeLists.txt10
1 files changed, 10 insertions, 0 deletions
diff --git a/Tests/VSMASM/CMakeLists.txt b/Tests/VSMASM/CMakeLists.txt
new file mode 100644
index 0000000..f2570a3
--- /dev/null
+++ b/Tests/VSMASM/CMakeLists.txt
@@ -0,0 +1,10 @@
+cmake_minimum_required(VERSION 2.8.12)
+project(VSMASM C ASM_MASM)
+if(CMAKE_SIZEOF_VOID_P EQUAL 8)
+ add_definitions(-DTESTx64)
+else()
+ add_definitions(-DTESTi386)
+ set(CMAKE_ASM_MASM_FLAGS "${CMAKE_ASM_MASM_FLAGS} /safeseh")
+endif()
+include_directories(${CMAKE_CURRENT_SOURCE_DIR}/include)
+add_executable(VSMASM main.c foo.asm)