summaryrefslogtreecommitdiffstats
path: root/Tests/X11/CMakeLists.txt
diff options
context:
space:
mode:
authorDavid Cole <david.cole@kitware.com>2009-01-21 16:54:30 (GMT)
committerDavid Cole <david.cole@kitware.com>2009-01-21 16:54:30 (GMT)
commitc647ed54d9c071393e95b204aac2bb975ec95fe9 (patch)
treede2b8f9c339804962fdf912d9837410cec5e3e60 /Tests/X11/CMakeLists.txt
parentd2f27558dfe6ab7c3a36b631249c9e3b89e9eb28 (diff)
downloadCMake-c647ed54d9c071393e95b204aac2bb975ec95fe9.zip
CMake-c647ed54d9c071393e95b204aac2bb975ec95fe9.tar.gz
CMake-c647ed54d9c071393e95b204aac2bb975ec95fe9.tar.bz2
BUG: Fix issue #7833: Add file extension handling to CPack generated installers for OSXX11 applications. Also modify the X11 test to build such an installer on Mac builds that test CPack and have X11 available. Thanks to Wes Turner for the patch.
Diffstat (limited to 'Tests/X11/CMakeLists.txt')
-rw-r--r--Tests/X11/CMakeLists.txt11
1 files changed, 8 insertions, 3 deletions
diff --git a/Tests/X11/CMakeLists.txt b/Tests/X11/CMakeLists.txt
index 52f4a6f..cc24464 100644
--- a/Tests/X11/CMakeLists.txt
+++ b/Tests/X11/CMakeLists.txt
@@ -6,6 +6,7 @@ INCLUDE (${CMAKE_ROOT}/Modules/FindX11.cmake)
MESSAGE("X11_FOUND: ${X11_FOUND}")
ADD_EXECUTABLE (UseX11 X11.c)
+install(TARGETS UseX11 DESTINATION bin)
# so for universal binaries this test will fail if
#
@@ -26,10 +27,14 @@ IF(X11_FOUND)
IF(APPLE)
ADD_EXECUTABLE(HelloWorldX11 HelloWorldX11.cxx)
TARGET_LINK_LIBRARIES(HelloWorldX11 ${X11_LIBRARIES})
- install( TARGETS HelloWorldX11 DESTINATION bin)
- # build a CPack driven installer package
+ install(TARGETS HelloWorldX11 DESTINATION bin)
+
+ set(CPACK_BINARY_OSXX11 "ON")
+ set(CPACK_BINARY_PACKAGEMAKER "OFF")
set(CPACK_PACKAGE_NAME HelloWorldX11Package)
set(CPACK_PACKAGE_EXECUTABLES HelloWorldX11 HelloWorldX11)
- include(CPack)
ENDIF(APPLE)
ENDIF(X11_FOUND)
+
+# build a CPack driven installer package
+include(CPack)