summaryrefslogtreecommitdiffstats
path: root/Utilities/cmliblzma/CMakeLists.txt
diff options
context:
space:
mode:
authorChuck Atkins <chuck.atkins@kitware.com>2014-11-03 19:37:12 (GMT)
committerChuck Atkins <chuck.atkins@kitware.com>2014-11-03 19:37:12 (GMT)
commit996f822930b02fbf6f7b1bc2fa21ad52b10ebdcd (patch)
tree51c604821d1594e9b519da860f9a9b86b14ba796 /Utilities/cmliblzma/CMakeLists.txt
parent40bab8d17b18ca5e6864bf282326507c59826021 (diff)
downloadCMake-996f822930b02fbf6f7b1bc2fa21ad52b10ebdcd.zip
CMake-996f822930b02fbf6f7b1bc2fa21ad52b10ebdcd.tar.gz
CMake-996f822930b02fbf6f7b1bc2fa21ad52b10ebdcd.tar.bz2
liblzma: fix build on platforms with no SIZE_MAX defined.
Some systems don't define a SIZE_MAX (older versions of HP-UX with aCC). The logic was already in place to account for this condition but SIZEOF_SIZE_T was not getting cmoputed at configure time to allow it to function. This computes sizeof(size_t) at configure time to allow the appropriate logic to work. It also changes SIZEOF_SIZE_T to SIZE_OF_SIZE_T for consistency.
Diffstat (limited to 'Utilities/cmliblzma/CMakeLists.txt')
-rw-r--r--Utilities/cmliblzma/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/Utilities/cmliblzma/CMakeLists.txt b/Utilities/cmliblzma/CMakeLists.txt
index c03147f..d991438 100644
--- a/Utilities/cmliblzma/CMakeLists.txt
+++ b/Utilities/cmliblzma/CMakeLists.txt
@@ -95,6 +95,7 @@ CHECK_TYPE_SIZE("unsigned short" SIZE_OF_UNSIGNED_SHORT)
CHECK_TYPE_SIZE("unsigned" SIZE_OF_UNSIGNED)
CHECK_TYPE_SIZE("unsigned long" SIZE_OF_UNSIGNED_LONG)
CHECK_TYPE_SIZE("unsigned long long" SIZE_OF_UNSIGNED_LONG_LONG)
+CHECK_TYPE_SIZE("size_t" SIZE_OF_SIZE_T)
CHECK_TYPE_SIZE("__int64" __INT64)
CHECK_TYPE_SIZE("unsigned __int64" UNSIGNED___INT64)