summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt11
1 files changed, 9 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index a5d7575..613ceaf 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -106,14 +106,21 @@ SET(CMAKE_XMLRPC_INCLUDES
SET(CMAKE_XMLRPC_LIBRARIES "cmXMLRPC")
IF (UNIX)
- INCLUDE (${CMake_SOURCE_DIR}/Modules/FindCurses.cmake OPTIONAL)
+ FIND_PACKAGE(Curses QUIET)
IF (CURSES_LIBRARY)
- SUBDIRS(Source/CursesDialog/form)
+ OPTION(BUILD_CursesDialog "Build the CMake Curses Dialog ccmake" ON)
ELSE (CURSES_LIBRARY)
MESSAGE("Curses libraries were not found. Curses GUI for CMake will not be build.")
+ SET(BUILD_CursesDialog 0)
ENDIF (CURSES_LIBRARY)
+ELSE (UNIX)
+ SET(BUILD_CursesDialog 0)
ENDIF (UNIX)
+IF(BUILD_CursesDialog)
+ SUBDIRS(Source/CursesDialog/form)
+ENDIF(BUILD_CursesDialog)
+
SUBDIRS(Source Modules Templates Utilities)
ENABLE_TESTING()