summaryrefslogtreecommitdiffstats
path: root/Tests/CustomCommandWorkingDirectory/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'Tests/CustomCommandWorkingDirectory/CMakeLists.txt')
-rw-r--r--Tests/CustomCommandWorkingDirectory/CMakeLists.txt11
1 files changed, 9 insertions, 2 deletions
diff --git a/Tests/CustomCommandWorkingDirectory/CMakeLists.txt b/Tests/CustomCommandWorkingDirectory/CMakeLists.txt
index d272ffe..36d32e4 100644
--- a/Tests/CustomCommandWorkingDirectory/CMakeLists.txt
+++ b/Tests/CustomCommandWorkingDirectory/CMakeLists.txt
@@ -10,6 +10,7 @@ ADD_CUSTOM_COMMAND(
SET_SOURCE_FILES_PROPERTIES(
"${TestWorkingDir_BINARY_DIR}/customTarget.c"
+ "${TestWorkingDir_BINARY_DIR}/customTarget2.c"
PROPERTIES GENERATED 1)
ADD_EXECUTABLE(working "${TestWorkingDir_BINARY_DIR}/working.c"
@@ -28,8 +29,14 @@ add_custom_command(
OUTPUT working2.c # Relative to build tree
COMMAND "${CMAKE_COMMAND}" -E copy ${TestWorkingDir_SOURCE_DIR}/working.c.in ../working2.c
DEPENDS ${TestWorkingDir_SOURCE_DIR}/working.c.in/ # trailing slash should be removed
- WORKING_DIRECTORY ${TestWorkingDir_BINARY_DIR}/work
+ WORKING_DIRECTORY work/ # Relative to build tree, trailing slash
)
-add_executable(working2 working2.c ${TestWorkingDir_BINARY_DIR}/customTarget.c)
+add_executable(working2 working2.c ${TestWorkingDir_BINARY_DIR}/customTarget2.c)
+
+add_custom_target(
+ Custom2 ALL
+ COMMAND "${CMAKE_COMMAND}" -E copy_if_different ${TestWorkingDir_SOURCE_DIR}/customTarget.c ../customTarget2.c
+ WORKING_DIRECTORY work/ # Relative to build tree, trailing slash
+)
add_dependencies(working2 Custom2)