summaryrefslogtreecommitdiffstats
path: root/Tests/PrecompiledHeader/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'Tests/PrecompiledHeader/CMakeLists.txt')
-rw-r--r--Tests/PrecompiledHeader/CMakeLists.txt61
1 files changed, 61 insertions, 0 deletions
diff --git a/Tests/PrecompiledHeader/CMakeLists.txt b/Tests/PrecompiledHeader/CMakeLists.txt
new file mode 100644
index 0000000..ac0e515
--- /dev/null
+++ b/Tests/PrecompiledHeader/CMakeLists.txt
@@ -0,0 +1,61 @@
+PROJECT(PrecompiledHeader C)
+
+# Make sure the proper compiler is in use.
+IF(NOT MSVC)
+ MESSAGE(FATAL_ERROR "The PrecompiledHeader test works only with MSVC")
+ENDIF(NOT MSVC)
+
+# Compute a custom name for the precompiled header.
+IF(CMAKE_CONFIGURATION_TYPES)
+ SET(PCH_DIR "${CMAKE_CURRENT_BINARY_DIR}/PCH/${CMAKE_CFG_INTDIR}")
+ELSE(CMAKE_CONFIGURATION_TYPES)
+ SET(PCH_DIR "${CMAKE_CURRENT_BINARY_DIR}/PCH")
+ENDIF(CMAKE_CONFIGURATION_TYPES)
+FILE(MAKE_DIRECTORY ${CMAKE_CURRENT_BINARY_DIR}/PCH)
+
+# Choose between an explicit include path and using /I during
+# precompilation. The /I form is provided as an example. In practice
+# the include path form would be used.
+SET(PCH_USE_INCLUDE_DIR 1)
+IF(PCH_USE_INCLUDE_DIR)
+ INCLUDE_DIRECTORIES(${CMAKE_CURRENT_SOURCE_DIR}/include)
+ELSE(PCH_USE_INCLUDE_DIR)
+ SET(PCH_INCLUDE_DIR "\"/I${CMAKE_CURRENT_SOURCE_DIR}/include\"")
+ENDIF(PCH_USE_INCLUDE_DIR)
+
+# The VS6 IDE does not support renaming .pch files so we cannot use a
+# separate target.
+IF(NOT "${CMAKE_GENERATOR}" MATCHES "Visual Studio 6")
+ SET(PCH_USE_TARGET 1)
+ENDIF(NOT "${CMAKE_GENERATOR}" MATCHES "Visual Studio 6")
+
+# Create a target that will use a precompiled header.
+SET(foo_SRCS foo1.c foo2.c)
+IF(PCH_USE_TARGET)
+ ADD_EXECUTABLE(foo ${foo_SRCS})
+
+ # Create a target to precompile the header for the executable.
+ ADD_LIBRARY(foo_precompile foo_precompile.c include/foo_precompiled.h)
+ SET_TARGET_PROPERTIES(foo_precompile PROPERTIES OUTPUT_NAME foo)
+ ADD_DEPENDENCIES(foo foo_precompile)
+
+ SET(PCH_TARGETS foo foo_precompile)
+ SET(PCH_FILE "\"/Fp${PCH_DIR}/foo_precompiled.pch\"")
+ELSE(PCH_USE_TARGET)
+ # Put the precompiled header source directly in the target.
+ ADD_EXECUTABLE(foo foo_precompile.c ${foo_SRCS})
+ SET(PCH_TARGETS foo)
+ENDIF(PCH_USE_TARGET)
+
+# Setup flags on the two targets to create and use the precompiled header.
+SET_TARGET_PROPERTIES(${PCH_TARGETS} PROPERTIES COMPILE_FLAGS
+ "/Yufoo_precompiled.h /FIfoo_precompiled.h ${PCH_FILE}")
+SET_SOURCE_FILES_PROPERTIES(foo_precompile.c PROPERTIES COMPILE_FLAGS
+ "/Ycfoo_precompiled.h ${PCH_INCLUDE_DIR}")
+
+# Make sure the object files rebuild when their precompiled header has changed.
+# The VS IDE takes care of this automatically.
+IF("${CMAKE_GENERATOR}" MATCHES "Makefile")
+ SET_SOURCE_FILES_PROPERTIES(${foo_SRCS} PROPERTIES
+ OBJECT_DEPENDS "${PCH_DIR}/foo_precompiled.pch")
+ENDIF("${CMAKE_GENERATOR}" MATCHES "Makefile")