summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in14
1 files changed, 13 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index 5b084e2..a464534 100644
--- a/configure.in
+++ b/configure.in
@@ -87,7 +87,19 @@ case $system in
echo "$ac_t""no" 1>&6
fi
rm -f conftest*
- ;;
+ ;;
+ OSF1-*)
+ echo $ac_n "checking whether ${CXX} accepts -std strict_ansi""... $ac_c" 1>&6
+ echo 'void f(){}' > conftest.c
+ if test -z "`${CXX} -std strict_ansi -c conftest.c 2>&1`"; then
+ echo "$ac_t""yes" 1>&6
+ CMAKE_ANSI_CXXFLAGS="-std strict_ansi"
+ else
+ echo "$ac_t""no" 1>&6
+ fi
+ rm -f conftest*
+ ;;
+
esac
fi
AC_SUBST(CMAKE_ANSI_CFLAGS)