summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2014-03-11 20:01:47 (GMT)
committerBrad King <brad.king@kitware.com>2014-03-24 15:37:20 (GMT)
commite1a13010eaedb2f9c91e2989f49a7dbf813e7137 (patch)
tree0917a08d28ec5aa73afdd1c8292a2c8a2ab6bafe /CMakeLists.txt
parentcfe97491eb0108dd7c8bc98c80426ae115cfe5f3 (diff)
downloadCastXML-e1a13010eaedb2f9c91e2989f49a7dbf813e7137.zip
CastXML-e1a13010eaedb2f9c91e2989f49a7dbf813e7137.tar.gz
CastXML-e1a13010eaedb2f9c91e2989f49a7dbf813e7137.tar.bz2
castxml: Use LLVM API to load command-line arguments
Use llvm::sys::Process::GetArgumentVector instead of KWSys Encoding to load process command-line arguments. This reduces dependency on KWSys and stores the arguments in LLVM-provided data structures.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 0 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 48e94d6..408698a 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -39,7 +39,6 @@ if("${CMAKE_CXX_COMPILER_ID}" MATCHES "GNU|Clang")
endif()
set(KWSYS_NAMESPACE cxsys)
-set(KWSYS_USE_Encoding 1)
set(KWSYS_USE_Process 1)
set(KWSYS_USE_RegularExpression 1)
set(KWSYS_USE_SystemTools 1)