summaryrefslogtreecommitdiffstats
path: root/test/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2014-03-05 20:13:17 (GMT)
committerBrad King <brad.king@kitware.com>2014-03-24 15:36:30 (GMT)
commit110dacffd23854ca3d668a5ecebf41ad0a207834 (patch)
tree29ff25f1ce5b4b9a686b7811d59f3772482a5a8d /test/CMakeLists.txt
parent5669ced871bbe3d74e9742ea6bb45b11fc5c8a57 (diff)
downloadCastXML-110dacffd23854ca3d668a5ecebf41ad0a207834.zip
CastXML-110dacffd23854ca3d668a5ecebf41ad0a207834.tar.gz
CastXML-110dacffd23854ca3d668a5ecebf41ad0a207834.tar.bz2
Output: Report class friends
Report in Class elements a befriending="" attribute listing the class friends. Queue the friends for output, but not necessarily as complete types.
Diffstat (limited to 'test/CMakeLists.txt')
-rw-r--r--test/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/test/CMakeLists.txt b/test/CMakeLists.txt
index 7ed3a96..ef8ec5b 100644
--- a/test/CMakeLists.txt
+++ b/test/CMakeLists.txt
@@ -70,6 +70,7 @@ castxml_test_gccxml(ArrayType-incomplete)
castxml_test_gccxml(Class)
castxml_test_gccxml(Class-abstract)
castxml_test_gccxml(Class-bases)
+castxml_test_gccxml(Class-friends)
castxml_test_gccxml(Class-incomplete)
castxml_test_gccxml(Class-template)
castxml_test_gccxml(CvQualifiedType)