summaryrefslogtreecommitdiffstats
path: root/test/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2014-04-10 15:29:17 (GMT)
committerBrad King <brad.king@kitware.com>2014-04-10 17:40:06 (GMT)
commit159fa06a9323e76e9cc2a67a899cc216f266bf5a (patch)
treeab39d00efa86518dfa8b37302f379a9382df047d /test/CMakeLists.txt
parent80d1be2da7aea241318130e4c49aebfe54377e29 (diff)
downloadCastXML-159fa06a9323e76e9cc2a67a899cc216f266bf5a.zip
CastXML-159fa06a9323e76e9cc2a67a899cc216f266bf5a.tar.gz
CastXML-159fa06a9323e76e9cc2a67a899cc216f266bf5a.tar.bz2
castxml: Register all LLVM target architectures and asm parsers
We need as parsers to support Visual Studio system header files that contain inline assembly.
Diffstat (limited to 'test/CMakeLists.txt')
-rw-r--r--test/CMakeLists.txt7
1 files changed, 7 insertions, 0 deletions
diff --git a/test/CMakeLists.txt b/test/CMakeLists.txt
index 05ffc70..af36e84 100644
--- a/test/CMakeLists.txt
+++ b/test/CMakeLists.txt
@@ -33,6 +33,7 @@ macro(castxml_test_gccxml_common prefix ext std test)
-std=${std}
${CMAKE_CURRENT_LIST_DIR}/input/${test}.${ext}
-o ${prefix}.${std}.${test}.xml
+ ${castxml_test_gccxml_extra_arguments}
)
add_test(
NAME ${prefix}.${std}.${test}
@@ -181,6 +182,12 @@ castxml_test_gccxml(using-declaration-start)
castxml_test_gccxml(using-directive-ns)
castxml_test_gccxml(using-directive-start)
+if(";${LLVM_TARGETS_TO_BUILD};" MATCHES ";X86;")
+ set(castxml_test_gccxml_extra_arguments -target i386-pc-windows-msvc)
+ castxml_test_gccxml(inline-asm-ms)
+ unset(castxml_test_gccxml_extra_arguments)
+endif()
+
castxml_test_gccxml_c(FundamentalType)
castxml_test_gccxml_c(Typedef-called-class)