summaryrefslogtreecommitdiffstats
path: root/test/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2014-04-11 18:49:22 (GMT)
committerBrad King <brad.king@kitware.com>2014-04-11 18:51:06 (GMT)
commit2bba2e9e8900666ca92a7abb848ee8e5756462d8 (patch)
tree359d4dd98514b54ccf2b71c1fb178fc21f8d3215 /test/CMakeLists.txt
parent81475d7fc881a5cdaa2e2a1e61ad335a52549093 (diff)
downloadCastXML-2bba2e9e8900666ca92a7abb848ee8e5756462d8.zip
CastXML-2bba2e9e8900666ca92a7abb848ee8e5756462d8.tar.gz
CastXML-2bba2e9e8900666ca92a7abb848ee8e5756462d8.tar.bz2
Output: Generate location attributes for builtin declarations
Report a file id "f0" named "<builtin>" for declarations that are generated by the compiler and have no reference location in the source. Add a test case covering the MSVC builtin "size_t" typedef.
Diffstat (limited to 'test/CMakeLists.txt')
-rw-r--r--test/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/test/CMakeLists.txt b/test/CMakeLists.txt
index 27b2972..22858aa 100644
--- a/test/CMakeLists.txt
+++ b/test/CMakeLists.txt
@@ -189,6 +189,7 @@ castxml_test_gccxml(using-directive-start)
if(";${LLVM_TARGETS_TO_BUILD};" MATCHES ";X86;")
set(castxml_test_gccxml_extra_arguments -target i386-pc-windows-msvc)
+ castxml_test_gccxml(implicit-decl-ms)
castxml_test_gccxml(inline-asm-ms)
unset(castxml_test_gccxml_extra_arguments)
endif()