summaryrefslogtreecommitdiffstats
path: root/test/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2014-03-04 19:26:54 (GMT)
committerBrad King <brad.king@kitware.com>2014-03-21 21:11:36 (GMT)
commit4036d255ab698632bb5414b1417e9107b2f62df7 (patch)
tree2ffa6278d6d39c43afdd0dd31cf250d4f80c8fe1 /test/CMakeLists.txt
parentc722f17c03226b1101cdd732e169360b5f9a81a0 (diff)
downloadCastXML-4036d255ab698632bb5414b1417e9107b2f62df7.zip
CastXML-4036d255ab698632bb5414b1417e9107b2f62df7.tar.gz
CastXML-4036d255ab698632bb5414b1417e9107b2f62df7.tar.bz2
Output: Generate Enumeration elements
Implement the OutputEnumDecl method to generate the Enumeration element. Report the name="", context="", and location="" of the declaration. Inside the Enumeration element generate EnumValue elements describing the enumeration names and initializers. Also map enum types to the corresponding declarations.
Diffstat (limited to 'test/CMakeLists.txt')
-rw-r--r--test/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/test/CMakeLists.txt b/test/CMakeLists.txt
index 1102aff..49ce30f 100644
--- a/test/CMakeLists.txt
+++ b/test/CMakeLists.txt
@@ -71,6 +71,7 @@ castxml_test_gccxml(Class)
castxml_test_gccxml(Class-incomplete)
castxml_test_gccxml(Class-template)
castxml_test_gccxml(CvQualifiedType)
+castxml_test_gccxml(Enumeration)
castxml_test_gccxml(Field)
castxml_test_gccxml(Function)
castxml_test_gccxml(Function-template)
@@ -91,6 +92,7 @@ castxml_test_gccxml(PointerType)
castxml_test_gccxml(ReferenceType)
castxml_test_gccxml(Typedef-paren)
castxml_test_gccxml(Typedef-to-Class-template)
+castxml_test_gccxml(Typedef-to-Enumeration)
castxml_test_gccxml(Variable)
castxml_test_gccxml(Variable-in-Class)
castxml_test_gccxml(Variable-init)