summaryrefslogtreecommitdiffstats
path: root/test/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2014-02-26 19:43:37 (GMT)
committerBrad King <brad.king@kitware.com>2014-03-21 21:04:46 (GMT)
commit55269737375c2168ac991e05f3fcd3777e4058b9 (patch)
tree9d28cbe52eb32780b76e3992ab7f0b50718a58ec /test/CMakeLists.txt
parent3edc5417f57d93f4a21ad185699e37c20576e71e (diff)
downloadCastXML-55269737375c2168ac991e05f3fcd3777e4058b9.zip
CastXML-55269737375c2168ac991e05f3fcd3777e4058b9.tar.gz
CastXML-55269737375c2168ac991e05f3fcd3777e4058b9.tar.bz2
test: Add cases for Method, OperatorMethod, and OperatorFunction
Use operator name "<<" and verify that the word "operator" does not appear in the name as is the case in original gccxml.
Diffstat (limited to 'test/CMakeLists.txt')
-rw-r--r--test/CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/test/CMakeLists.txt b/test/CMakeLists.txt
index 3a71aae..815060f 100644
--- a/test/CMakeLists.txt
+++ b/test/CMakeLists.txt
@@ -74,7 +74,10 @@ castxml_test_gccxml(CvQualifiedType)
castxml_test_gccxml(Function)
castxml_test_gccxml(Function-throw)
castxml_test_gccxml(FundamentalType)
+castxml_test_gccxml(Method)
castxml_test_gccxml(Namespace)
+castxml_test_gccxml(OperatorFunction)
+castxml_test_gccxml(OperatorMethod)
castxml_test_gccxml(PointerType)
castxml_test_gccxml(ReferenceType)
castxml_test_gccxml(Typedef-to-Class-template)