summaryrefslogtreecommitdiffstats
path: root/test/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2014-02-12 21:06:24 (GMT)
committerBrad King <brad.king@kitware.com>2014-03-21 18:38:42 (GMT)
commit5a5c1c8043ea4726546f003e47953d33975de54e (patch)
tree5f39498365d57f1c3ac104a0422796ba20362a96 /test/CMakeLists.txt
parent31df7b6834f7e053d0f131966d696682f71df84a (diff)
downloadCastXML-5a5c1c8043ea4726546f003e47953d33975de54e.zip
CastXML-5a5c1c8043ea4726546f003e47953d33975de54e.tar.gz
CastXML-5a5c1c8043ea4726546f003e47953d33975de54e.tar.bz2
Output: Generate declared Namespace elements
Implement the OutputNamespaceDecl method to generate a Namespace element for explicitly declared namespaces. Report the name="", context="", and members="" of the namespace. Queue its members.
Diffstat (limited to 'test/CMakeLists.txt')
-rw-r--r--test/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/test/CMakeLists.txt b/test/CMakeLists.txt
index 3bb3f1d..dd90307 100644
--- a/test/CMakeLists.txt
+++ b/test/CMakeLists.txt
@@ -50,3 +50,5 @@ castxml_test_cmd(gccxml-and-E --castxml-gccxml -E)
castxml_test_cmd(gccxml-twice --castxml-gccxml --castxml-gccxml)
castxml_test_cmd(o-missing -o)
castxml_test_cmd(start-missing --castxml-start)
+
+castxml_test_gccxml(Namespace)