summaryrefslogtreecommitdiffstats
path: root/test/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2014-03-06 20:07:35 (GMT)
committerBrad King <brad.king@kitware.com>2014-03-24 15:37:20 (GMT)
commit66e499376acbff61aece11ed8c0cef59c05aca3a (patch)
tree949a00a3ec501f15f0f4bab3822b86d6a47c3d2d /test/CMakeLists.txt
parent4c2326f24a266c2ee7b88b50c5655fb2edbd082c (diff)
downloadCastXML-66e499376acbff61aece11ed8c0cef59c05aca3a.zip
CastXML-66e499376acbff61aece11ed8c0cef59c05aca3a.tar.gz
CastXML-66e499376acbff61aece11ed8c0cef59c05aca3a.tar.bz2
Output: Make FundamentalType names match gccxml
The gccxml FundamentalType names used different variants for integer type names than Clang uses. Hard-code the names for these types. Add a test case to cover these names.
Diffstat (limited to 'test/CMakeLists.txt')
-rw-r--r--test/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/test/CMakeLists.txt b/test/CMakeLists.txt
index d3cb069..112d3c3 100644
--- a/test/CMakeLists.txt
+++ b/test/CMakeLists.txt
@@ -93,6 +93,7 @@ castxml_test_gccxml(Function-variadic)
castxml_test_gccxml(FunctionType)
castxml_test_gccxml(FunctionType-variadic)
castxml_test_gccxml(FundamentalType)
+castxml_test_gccxml(FundamentalTypes)
castxml_test_gccxml(Method)
castxml_test_gccxml(MethodType)
castxml_test_gccxml(MethodType-cv)