summaryrefslogtreecommitdiffstats
path: root/test/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2014-02-12 21:18:04 (GMT)
committerBrad King <brad.king@kitware.com>2014-03-21 18:39:10 (GMT)
commit76c942fbf736356445ea9eabf4eccd1919ee2ce1 (patch)
tree64a6d054a09bca5f904d7675abcbe7e5ae0ba274 /test/CMakeLists.txt
parentab558c0e515e84e768835a13bab218ce487c8f89 (diff)
downloadCastXML-76c942fbf736356445ea9eabf4eccd1919ee2ce1.zip
CastXML-76c942fbf736356445ea9eabf4eccd1919ee2ce1.tar.gz
CastXML-76c942fbf736356445ea9eabf4eccd1919ee2ce1.tar.bz2
Output: Generate CvQualifiedType elements
Implement the OutputCvQualifiedType method to generate an element whose ID attribute id="" is that of an unqualified type plus 'c', 'v', or 'r' letters appended to indicate qualification. Reference the IDREF of the unqualified type in a type="" attribute and describe the qualifiers with const="1", volatile="1", and restrict="1" attributes as appropriate.
Diffstat (limited to 'test/CMakeLists.txt')
-rw-r--r--test/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/test/CMakeLists.txt b/test/CMakeLists.txt
index 67cc9c0..5eb89cd 100644
--- a/test/CMakeLists.txt
+++ b/test/CMakeLists.txt
@@ -51,5 +51,6 @@ castxml_test_cmd(gccxml-twice --castxml-gccxml --castxml-gccxml)
castxml_test_cmd(o-missing -o)
castxml_test_cmd(start-missing --castxml-start)
+castxml_test_gccxml(CvQualifiedType)
castxml_test_gccxml(FundamentalType)
castxml_test_gccxml(Namespace)