summaryrefslogtreecommitdiffstats
path: root/test/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2015-09-02 18:40:45 (GMT)
committerBrad King <brad.king@kitware.com>2015-09-02 18:46:37 (GMT)
commit7acd634c8ab5349a4946bbfe66e24e4ce30f90b9 (patch)
tree447026c0c603f23a938537494f40ff9579dd478f /test/CMakeLists.txt
parenta2b9e1a10c9bedc8a2212096bc10206ed4bfce60 (diff)
downloadCastXML-7acd634c8ab5349a4946bbfe66e24e4ce30f90b9.zip
CastXML-7acd634c8ab5349a4946bbfe66e24e4ce30f90b9.tar.gz
CastXML-7acd634c8ab5349a4946bbfe66e24e4ce30f90b9.tar.bz2
castxml: Support -std=c++14 with --castxml-gccxml
Drop the rejection of -std=c++14 and --castxml-gccxml together. Extend the test suite to run all gccxml output format tests in -std=c++14 mode to verify the behavior of the mode is as close as possible to other modes. For the few tests that have c++11-specific expected output, use it for c++14 expected output too.
Diffstat (limited to 'test/CMakeLists.txt')
-rw-r--r--test/CMakeLists.txt10
1 files changed, 10 insertions, 0 deletions
diff --git a/test/CMakeLists.txt b/test/CMakeLists.txt
index 7c23299..b85b49a 100644
--- a/test/CMakeLists.txt
+++ b/test/CMakeLists.txt
@@ -75,6 +75,10 @@ macro(castxml_test_gccxml_cxx11 test)
castxml_test_gccxml_common(gccxml cxx c++11 ${test})
endmacro()
+macro(castxml_test_gccxml_cxx14 test)
+ castxml_test_gccxml_common(gccxml cxx c++14 ${test})
+endmacro()
+
macro(castxml_test_gccxml_broken_cxx98 test)
castxml_test_gccxml_common(gccxml.broken cxx c++98 ${test})
endmacro()
@@ -83,6 +87,10 @@ macro(castxml_test_gccxml_broken_cxx11 test)
castxml_test_gccxml_common(gccxml.broken cxx c++11 ${test})
endmacro()
+macro(castxml_test_gccxml_broken_cxx14 test)
+ castxml_test_gccxml_common(gccxml.broken cxx c++14 ${test})
+endmacro()
+
macro(castxml_test_gccxml_c test)
castxml_test_gccxml_c89(${test})
endmacro()
@@ -90,11 +98,13 @@ endmacro()
macro(castxml_test_gccxml test)
castxml_test_gccxml_cxx98(${test})
castxml_test_gccxml_cxx11(${test})
+ castxml_test_gccxml_cxx14(${test})
endmacro()
macro(castxml_test_gccxml_broken test)
castxml_test_gccxml_broken_cxx98(${test})
castxml_test_gccxml_broken_cxx11(${test})
+ castxml_test_gccxml_broken_cxx14(${test})
endmacro()
set(input ${CMAKE_CURRENT_LIST_DIR}/input)