summaryrefslogtreecommitdiffstats
path: root/test/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2014-03-31 14:58:45 (GMT)
committerBrad King <brad.king@kitware.com>2014-03-31 14:58:45 (GMT)
commit7b6294eef526429d1124acbdc258e09c8be217a3 (patch)
tree4a34e954fb21d5353dac261ee3fd21ff809a12f2 /test/CMakeLists.txt
parente2e8a196b04868ebaa739af1f1bffbd907e78ada (diff)
downloadCastXML-7b6294eef526429d1124acbdc258e09c8be217a3.zip
CastXML-7b6294eef526429d1124acbdc258e09c8be217a3.tar.gz
CastXML-7b6294eef526429d1124acbdc258e09c8be217a3.tar.bz2
Output: Skip friend function templates
The gccxml output format does not support uninstantiated templates so we need to skip friend declarations referencing them.
Diffstat (limited to 'test/CMakeLists.txt')
-rw-r--r--test/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/test/CMakeLists.txt b/test/CMakeLists.txt
index fd35886..158215a 100644
--- a/test/CMakeLists.txt
+++ b/test/CMakeLists.txt
@@ -104,6 +104,7 @@ castxml_test_gccxml(Class-member-template)
castxml_test_gccxml(Class-template)
castxml_test_gccxml(Class-template-Method-Argument-default)
castxml_test_gccxml(Class-template-bases)
+castxml_test_gccxml(Class-template-friends)
castxml_test_gccxml(Class-template-member-Typedef)
castxml_test_gccxml(Class-template-member-template)
castxml_test_gccxml(CvQualifiedType)