summaryrefslogtreecommitdiffstats
path: root/test/CMakeLists.txt
diff options
context:
space:
mode:
authorGaƫtan Lehmann <gaetan.lehmann@gmail.com>2015-01-28 08:27:40 (GMT)
committerBrad King <brad.king@kitware.com>2015-01-28 15:06:20 (GMT)
commit7cdf28e815b45e8584a7f06d457365f3f4963d02 (patch)
treebd9670d8aa9c401f007d212f1caa8bb548f88532 /test/CMakeLists.txt
parentcd657a281917fac2a954b3659a8c8b9ee57991ce (diff)
downloadCastXML-7cdf28e815b45e8584a7f06d457365f3f4963d02.zip
CastXML-7cdf28e815b45e8584a7f06d457365f3f4963d02.tar.gz
CastXML-7cdf28e815b45e8584a7f06d457365f3f4963d02.tar.bz2
castxml: Allow -E to suppress --castxml-gccxml when used together
This helps make castxml usable with ccache. In its first pass, ccache drops the -o and the output file from the command line and add the -E option to get the preprocessed output. It does not now about --castxml-gccxml, so castxml must not produce an error when the options are used together. Instead make -E suppress --castxml-gccxml, much like compilers do for -E and -c together. Co-Author: Brad King <brad.king@kitware.com>
Diffstat (limited to 'test/CMakeLists.txt')
-rw-r--r--test/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/test/CMakeLists.txt b/test/CMakeLists.txt
index fd666b6..0942cf4 100644
--- a/test/CMakeLists.txt
+++ b/test/CMakeLists.txt
@@ -113,6 +113,7 @@ castxml_test_cmd(gccxml-and-c++14 --castxml-gccxml -std=c++14 ${empty_cxx})
castxml_test_cmd(gccxml-and-objc1 --castxml-gccxml ${empty_m})
castxml_test_cmd(gccxml-and-objc2 --castxml-gccxml ${empty_mm})
castxml_test_cmd(gccxml-empty-c++98 --castxml-gccxml -std=c++98 ${empty_cxx})
+castxml_test_cmd(gccxml-empty-c++98-E --castxml-gccxml -std=c++98 ${empty_cxx} -E)
castxml_test_cmd(o-missing -o)
castxml_test_cmd(start-missing --castxml-start)
castxml_test_cmd(rsp-empty @${input}/empty.rsp)