summaryrefslogtreecommitdiffstats
path: root/test/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2014-04-09 20:17:56 (GMT)
committerBrad King <brad.king@kitware.com>2014-04-09 20:44:13 (GMT)
commit831ffbfb9a9e57436058eaead8eedf081b03103e (patch)
tree6adf288649ebff5aa5c6d2c7931ed585e1973fd9 /test/CMakeLists.txt
parent174356cdb7f27e741f9668883d1c5d558e20bc6b (diff)
downloadCastXML-831ffbfb9a9e57436058eaead8eedf081b03103e.zip
CastXML-831ffbfb9a9e57436058eaead8eedf081b03103e.tar.gz
CastXML-831ffbfb9a9e57436058eaead8eedf081b03103e.tar.bz2
test: Name expected results by language standard
Name files "gccxml.<std>.<test>.(stdout|stderr|result|xml).txt" where "<std>" is either the language standard or "any" if the result works for any standard.
Diffstat (limited to 'test/CMakeLists.txt')
-rw-r--r--test/CMakeLists.txt10
1 files changed, 5 insertions, 5 deletions
diff --git a/test/CMakeLists.txt b/test/CMakeLists.txt
index 0c6550d..4d6b0dc 100644
--- a/test/CMakeLists.txt
+++ b/test/CMakeLists.txt
@@ -32,14 +32,14 @@ macro(castxml_test_gccxml_common prefix ext std test)
--castxml-gccxml --castxml-start start
-std=${std}
${CMAKE_CURRENT_LIST_DIR}/input/${test}.${ext}
- -o ${prefix}.${test}.xml
+ -o ${prefix}.${std}.${test}.xml
)
add_test(
- NAME ${prefix}.${test}
+ NAME ${prefix}.${std}.${test}
COMMAND ${CMAKE_COMMAND}
"-Dcommand:STRING=${command}"
- "-Dexpect=${prefix}.${test}"
- "-Dxml=${prefix}.${test}.xml"
+ "-Dexpect=${prefix}.${std}.${test};${prefix}.any.${test}"
+ "-Dxml=${prefix}.${std}.${test}.xml"
"-Dxmllint=${LIBXML2_XMLLINT_EXECUTABLE}"
-P ${CMAKE_CURRENT_SOURCE_DIR}/run.cmake
)
@@ -54,7 +54,7 @@ macro(castxml_test_gccxml_broken test)
endmacro()
macro(castxml_test_gccxml_c test)
- castxml_test_gccxml_common(gccxml.c c c89 ${test})
+ castxml_test_gccxml_common(gccxml c c89 ${test})
endmacro()
set(input ${CMAKE_CURRENT_LIST_DIR}/input)