summaryrefslogtreecommitdiffstats
path: root/test/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2015-08-07 12:58:11 (GMT)
committerBrad King <brad.king@kitware.com>2015-08-07 12:58:11 (GMT)
commit8a08a44ffee70f71bdb7d8bee90e325dafbfeae4 (patch)
tree7190cb9dbe1bb3101437bd7f05dc4d6f136cdec6 /test/CMakeLists.txt
parent7fbf764f3a2945710d78fb0f6a1a937501df8166 (diff)
downloadCastXML-8a08a44ffee70f71bdb7d8bee90e325dafbfeae4.zip
CastXML-8a08a44ffee70f71bdb7d8bee90e325dafbfeae4.tar.gz
CastXML-8a08a44ffee70f71bdb7d8bee90e325dafbfeae4.tar.bz2
RunClang: Exit with error if compilation jobs fail to build
If an error occurs during Driver::BuildCompilation then exit with an error code immediately. This is important when an input file is missing, for example. GitHub-Issue: 23
Diffstat (limited to 'test/CMakeLists.txt')
-rw-r--r--test/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/test/CMakeLists.txt b/test/CMakeLists.txt
index a104cb9..f44680f 100644
--- a/test/CMakeLists.txt
+++ b/test/CMakeLists.txt
@@ -126,6 +126,7 @@ castxml_test_cmd(gccxml-and-objc2 --castxml-gccxml ${empty_mm})
castxml_test_cmd(gccxml-empty-c++98 --castxml-gccxml -std=c++98 ${empty_cxx})
castxml_test_cmd(gccxml-empty-c++98-E --castxml-gccxml -std=c++98 ${empty_cxx} -E)
castxml_test_cmd(gccxml-empty-c++98-c --castxml-gccxml -std=c++98 ${empty_cxx} -c)
+castxml_test_cmd(input-missing ${input}/does-not-exist.c)
castxml_test_cmd(o-missing -o)
castxml_test_cmd(start-missing --castxml-start)
castxml_test_cmd(rsp-empty @${input}/empty.rsp)