summaryrefslogtreecommitdiffstats
path: root/test/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2014-03-18 17:43:41 (GMT)
committerBrad King <brad.king@kitware.com>2014-03-24 15:37:20 (GMT)
commit8b1ff3b91b2f5e9e9da2277131e5d303923edbb4 (patch)
tree585cd086ee02a60014b7df7ebaa2d51ce8f9b0f0 /test/CMakeLists.txt
parent2ccf3b840d595a2dcc154358d9effc0a93f5606b (diff)
downloadCastXML-8b1ff3b91b2f5e9e9da2277131e5d303923edbb4.zip
CastXML-8b1ff3b91b2f5e9e9da2277131e5d303923edbb4.tar.gz
CastXML-8b1ff3b91b2f5e9e9da2277131e5d303923edbb4.tar.bz2
Output: Desugar Class base class references
Report the canonical base type instead of a typedef type in order to match gccxml behavior.
Diffstat (limited to 'test/CMakeLists.txt')
-rw-r--r--test/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/test/CMakeLists.txt b/test/CMakeLists.txt
index 5d1e255..e59d195 100644
--- a/test/CMakeLists.txt
+++ b/test/CMakeLists.txt
@@ -82,6 +82,7 @@ castxml_test_gccxml(ArrayType)
castxml_test_gccxml(ArrayType-incomplete)
castxml_test_gccxml(Class)
castxml_test_gccxml(Class-abstract)
+castxml_test_gccxml(Class-base-typedef)
castxml_test_gccxml(Class-bases)
castxml_test_gccxml(Class-forward)
castxml_test_gccxml(Class-friends)