summaryrefslogtreecommitdiffstats
path: root/test/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2014-03-27 18:18:33 (GMT)
committerBrad King <brad.king@kitware.com>2014-03-27 18:18:50 (GMT)
commit8dea3e2fe710eb109a734c7fdb991ae6470cb4cd (patch)
tree0c7c589fc38978381bf36224a610b6f60baf37cc /test/CMakeLists.txt
parentfc66c82e1de6afd4453b7223c51de50428a40769 (diff)
downloadCastXML-8dea3e2fe710eb109a734c7fdb991ae6470cb4cd.zip
CastXML-8dea3e2fe710eb109a734c7fdb991ae6470cb4cd.tar.gz
CastXML-8dea3e2fe710eb109a734c7fdb991ae6470cb4cd.tar.bz2
test: Use distinct output xml for every test
Use the castxml "-o" option to place the test output in a .xml file named for the test instead of the input file. This allows multiple tests to share the same input file base name and still run in parallel without conflict.
Diffstat (limited to 'test/CMakeLists.txt')
-rw-r--r--test/CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/test/CMakeLists.txt b/test/CMakeLists.txt
index 2d376ba..fd35886 100644
--- a/test/CMakeLists.txt
+++ b/test/CMakeLists.txt
@@ -32,13 +32,14 @@ macro(castxml_test_gccxml_common prefix ext std test)
--castxml-gccxml --castxml-start start
${std}
${CMAKE_CURRENT_LIST_DIR}/input/${test}.${ext}
+ -o ${prefix}.${test}.xml
)
add_test(
NAME ${prefix}.${test}
COMMAND ${CMAKE_COMMAND}
"-Dcommand:STRING=${command}"
"-Dtest=${prefix}.${test}"
- "-Dxml=${test}.xml"
+ "-Dxml=${prefix}.${test}.xml"
"-Dxmllint=${LIBXML2_XMLLINT_EXECUTABLE}"
-P ${CMAKE_CURRENT_SOURCE_DIR}/run.cmake
)