summaryrefslogtreecommitdiffstats
path: root/test/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2016-10-06 13:37:11 (GMT)
committerBrad King <brad.king@kitware.com>2016-10-06 13:40:34 (GMT)
commit96bafbccfdc0c3055d152db42de4780b5120c6e5 (patch)
treed0d4faf6bfca68173af3cbe34098f1e7e3f35111 /test/CMakeLists.txt
parente1ee6852c79eddafa2ce1f134c097decd27aaa69 (diff)
downloadCastXML-96bafbccfdc0c3055d152db42de4780b5120c6e5.zip
CastXML-96bafbccfdc0c3055d152db42de4780b5120c6e5.tar.gz
CastXML-96bafbccfdc0c3055d152db42de4780b5120c6e5.tar.bz2
Output: Avoid assertion failure on a FunctionDecl with no identifier
All C++98 function declarations have identifiers as names. Some C++11 function declarations, such as user defined literal operators, do not have identifiers. While we may implement support for these in a future non-gccxml output format, for now simply avoid an assertion failure by outputting such declarations as Unimplemented nodes. Issue: #76
Diffstat (limited to 'test/CMakeLists.txt')
-rw-r--r--test/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/test/CMakeLists.txt b/test/CMakeLists.txt
index a039396..1bf4613 100644
--- a/test/CMakeLists.txt
+++ b/test/CMakeLists.txt
@@ -315,6 +315,7 @@ castxml_test_gccxml(Constructor-annotate)
castxml_test_gccxml(Converter)
castxml_test_gccxml(Converter-annotate)
castxml_test_gccxml(CvQualifiedType)
+castxml_test_gccxml(CXXLiteral)
castxml_test_gccxml(Destructor)
castxml_test_gccxml(Destructor-annotate)
castxml_test_gccxml(Enumeration)